summaryrefslogtreecommitdiffstats
path: root/vendor/pkcs8/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/pkcs8/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/pkcs8/Cargo.toml')
-rw-r--r--vendor/pkcs8/Cargo.toml109
1 files changed, 109 insertions, 0 deletions
diff --git a/vendor/pkcs8/Cargo.toml b/vendor/pkcs8/Cargo.toml
new file mode 100644
index 000000000..6de007a54
--- /dev/null
+++ b/vendor/pkcs8/Cargo.toml
@@ -0,0 +1,109 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57"
+name = "pkcs8"
+version = "0.9.0"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of Public-Key Cryptography Standards (PKCS) #8:
+Private-Key Information Syntax Specification (RFC 5208), with additional
+support for PKCS#8v2 asymmetric key packages (RFC 5958)
+"""
+readme = "README.md"
+keywords = [
+ "crypto",
+ "key",
+ "pkcs",
+ "private",
+]
+categories = [
+ "cryptography",
+ "data-structures",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/pkcs8"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.der]
+version = "0.6"
+features = ["oid"]
+
+[dependencies.pkcs5]
+version = "0.5"
+optional = true
+
+[dependencies.rand_core]
+version = "0.6"
+optional = true
+default-features = false
+
+[dependencies.spki]
+version = "0.6"
+
+[dependencies.subtle]
+version = "2"
+optional = true
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+3des = [
+ "encryption",
+ "pkcs5/3des",
+]
+alloc = [
+ "der/alloc",
+ "der/zeroize",
+ "spki/alloc",
+]
+des-insecure = [
+ "encryption",
+ "pkcs5/des-insecure",
+]
+encryption = [
+ "alloc",
+ "pkcs5/alloc",
+ "pkcs5/pbes2",
+ "rand_core",
+]
+getrandom = ["rand_core/getrandom"]
+pem = [
+ "alloc",
+ "der/pem",
+ "spki/pem",
+]
+sha1 = [
+ "encryption",
+ "pkcs5/sha1",
+]
+std = [
+ "alloc",
+ "der/std",
+ "spki/std",
+]