summaryrefslogtreecommitdiffstats
path: root/vendor/portable-atomic/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/portable-atomic/Cargo.toml
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/portable-atomic/Cargo.toml')
-rw-r--r--vendor/portable-atomic/Cargo.toml93
1 files changed, 93 insertions, 0 deletions
diff --git a/vendor/portable-atomic/Cargo.toml b/vendor/portable-atomic/Cargo.toml
new file mode 100644
index 000000000..c2e30ea38
--- /dev/null
+++ b/vendor/portable-atomic/Cargo.toml
@@ -0,0 +1,93 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.34"
+name = "portable-atomic"
+version = "1.4.2"
+exclude = [
+ "/.*",
+ "/tools",
+ "/target-specs",
+ "/Cross.toml",
+ "/DEVELOPMENT.md",
+]
+description = """
+Portable atomic types including support for 128-bit atomics, atomic float, etc.
+"""
+readme = "README.md"
+keywords = ["atomic"]
+categories = [
+ "concurrency",
+ "embedded",
+ "hardware-support",
+ "no-std",
+ "no-std::no-alloc",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/taiki-e/portable-atomic"
+
+[package.metadata.docs.rs]
+features = [
+ "float",
+ "std",
+ "serde",
+ "critical-section",
+]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
+[dependencies.critical-section]
+version = "1"
+optional = true
+
+[dependencies.serde]
+version = "1.0.103"
+optional = true
+default-features = false
+
+[dev-dependencies.build-context]
+version = "0.1"
+
+[dev-dependencies.crossbeam-utils]
+version = "0.8"
+
+[dev-dependencies.fastrand]
+version = "2"
+
+[dev-dependencies.paste]
+version = "1"
+
+[dev-dependencies.serde_test]
+version = "1"
+
+[dev-dependencies.sptr]
+version = "0.3"
+
+[dev-dependencies.static_assertions]
+version = "1"
+
+[features]
+default = ["fallback"]
+disable-fiq = []
+fallback = []
+float = []
+require-cas = []
+s-mode = []
+std = []
+unsafe-assume-single-core = []