summaryrefslogtreecommitdiffstats
path: root/vendor/precomputed-hash
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/precomputed-hash
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/precomputed-hash')
-rw-r--r--vendor/precomputed-hash/.cargo-checksum.json1
-rw-r--r--vendor/precomputed-hash/Cargo.toml21
-rw-r--r--vendor/precomputed-hash/LICENSE21
-rw-r--r--vendor/precomputed-hash/src/lib.rs22
4 files changed, 65 insertions, 0 deletions
diff --git a/vendor/precomputed-hash/.cargo-checksum.json b/vendor/precomputed-hash/.cargo-checksum.json
new file mode 100644
index 000000000..a41fee4ec
--- /dev/null
+++ b/vendor/precomputed-hash/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"594bc4437727edbf58c7cb9f88c3c1d80e89439dd4a505ef4771f9f344819386","LICENSE":"7ca6700600dfa9c9497bf5556365067daa802c871ea78239f129309c7a2048f7","src/lib.rs":"079a5f369a82b4573cca488a8c52a8427546e9050c89964a7b554215dd4da5f1"},"package":"925383efa346730478fb4838dbe9137d2a47675ad789c546d150a6e1dd4ab31c"} \ No newline at end of file
diff --git a/vendor/precomputed-hash/Cargo.toml b/vendor/precomputed-hash/Cargo.toml
new file mode 100644
index 000000000..64acf0e49
--- /dev/null
+++ b/vendor/precomputed-hash/Cargo.toml
@@ -0,0 +1,21 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "precomputed-hash"
+version = "0.1.1"
+authors = ["Emilio Cobos Álvarez <emilio@crisal.io>"]
+description = "A library intending to be a base dependency to expose a precomputed hash"
+license = "MIT"
+repository = "https://github.com/emilio/precomputed-hash"
+
+[dependencies]
diff --git a/vendor/precomputed-hash/LICENSE b/vendor/precomputed-hash/LICENSE
new file mode 100644
index 000000000..c99e3b59a
--- /dev/null
+++ b/vendor/precomputed-hash/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Emilio Cobos Álvarez
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/vendor/precomputed-hash/src/lib.rs b/vendor/precomputed-hash/src/lib.rs
new file mode 100644
index 000000000..9cdb45d5b
--- /dev/null
+++ b/vendor/precomputed-hash/src/lib.rs
@@ -0,0 +1,22 @@
+//! A base trait to expose a precomputed hash for a type.
+
+/// A trait to expose a precomputed hash for a type.
+pub trait PrecomputedHash {
+ // TODO(emilio): Perhaps an associated type would be on point here.
+
+ /// Return the precomputed hash for this item.
+ fn precomputed_hash(&self) -> u32;
+}
+
+// These are equivalent to the `std::Hash` impls.
+impl<'a, T: PrecomputedHash> PrecomputedHash for &'a T {
+ fn precomputed_hash(&self) -> u32 {
+ (**self).precomputed_hash()
+ }
+}
+
+impl<'a, T: PrecomputedHash> PrecomputedHash for &'a mut T {
+ fn precomputed_hash(&self) -> u32 {
+ (**self).precomputed_hash()
+ }
+}