summaryrefslogtreecommitdiffstats
path: root/vendor/prodash/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/prodash/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/prodash/Cargo.toml')
-rw-r--r--vendor/prodash/Cargo.toml240
1 files changed, 240 insertions, 0 deletions
diff --git a/vendor/prodash/Cargo.toml b/vendor/prodash/Cargo.toml
new file mode 100644
index 000000000..f3ea2b598
--- /dev/null
+++ b/vendor/prodash/Cargo.toml
@@ -0,0 +1,240 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "prodash"
+version = "23.1.1"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "README.md",
+ "LICENSE.md",
+ "CHANGELOG.md",
+]
+description = "A dashboard for visualizing progress of asynchronous and possibly blocking tasks"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/Byron/prodash"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+doctest = true
+
+[[example]]
+name = "dashboard"
+path = "examples/dashboard.rs"
+required-features = [
+ "render-tui",
+ "render-tui-crossterm",
+ "render-line",
+ "render-line-crossterm",
+ "signal-hook",
+ "render-line-autoconfigure",
+ "progress-tree",
+]
+
+[[example]]
+name = "dashboard-termion"
+path = "examples/dashboard.rs"
+required-features = [
+ "render-tui",
+ "render-tui-termion",
+ "render-line",
+ "render-line-termion",
+ "progress-tree",
+]
+
+[[example]]
+name = "units"
+path = "examples/units.rs"
+required-features = [
+ "unit-bytes",
+ "unit-duration",
+ "unit-human",
+ "render-tui",
+ "render-tui-crossterm",
+ "render-line",
+ "render-line-crossterm",
+ "signal-hook",
+]
+
+[[bench]]
+name = "usage"
+path = "benches/usage.rs"
+harness = false
+
+[dependencies.async-io]
+version = "1.0.0"
+optional = true
+
+[dependencies.atty]
+version = "0.2.14"
+optional = true
+
+[dependencies.bytesize]
+version = "1.0.1"
+optional = true
+
+[dependencies.compound_duration]
+version = "1.2.0"
+optional = true
+
+[dependencies.crosstermion]
+version = "0.10.1"
+optional = true
+default-features = false
+
+[dependencies.ctrlc]
+version = "3.1.4"
+features = ["termination"]
+optional = true
+default-features = false
+
+[dependencies.dashmap]
+version = "5.1.0"
+optional = true
+default-features = false
+
+[dependencies.futures-core]
+version = "0.3.4"
+optional = true
+default-features = false
+
+[dependencies.futures-lite]
+version = "1.5.0"
+optional = true
+
+[dependencies.human_format]
+version = "1.0.3"
+optional = true
+
+[dependencies.humantime]
+version = "2.0.0"
+optional = true
+
+[dependencies.log]
+version = "0.4.8"
+optional = true
+
+[dependencies.parking_lot]
+version = "0.12.1"
+optional = true
+default-features = false
+
+[dependencies.signal-hook]
+version = "0.3.9"
+optional = true
+default-features = false
+
+[dependencies.time]
+version = "0.3.2"
+features = [
+ "std",
+ "local-offset",
+ "formatting",
+]
+optional = true
+default-features = false
+
+[dependencies.tui]
+version = "0.19.0"
+optional = true
+default-features = false
+
+[dependencies.tui-react]
+version = "0.19.0"
+optional = true
+
+[dependencies.unicode-segmentation]
+version = "1.6.0"
+optional = true
+
+[dependencies.unicode-width]
+version = "0.1.7"
+optional = true
+
+[dev-dependencies.argh]
+version = "0.1.3"
+
+[dev-dependencies.async-executor]
+version = "1.1.0"
+
+[dev-dependencies.async-io]
+version = "1.1.0"
+
+[dev-dependencies.atty]
+version = "0.2.14"
+
+[dev-dependencies.blocking]
+version = "1.0.0"
+
+[dev-dependencies.criterion]
+version = "0.4.0"
+default-features = false
+
+[dev-dependencies.env_logger]
+version = "0.10.0"
+features = ["humantime"]
+default-features = false
+
+[dev-dependencies.futures]
+version = "0.3.5"
+
+[dev-dependencies.futures-util]
+version = "0.3.4"
+default-features = false
+
+[dev-dependencies.once_cell]
+version = "1.4.0"
+
+[dev-dependencies.rand]
+version = "0.8.1"
+
+[features]
+default = [
+ "progress-tree",
+ "progress-tree-log",
+]
+local-time = ["time"]
+progress-log = ["log"]
+progress-tree = ["parking_lot"]
+progress-tree-hp-hashmap = ["dashmap"]
+progress-tree-log = ["log"]
+render-line = [
+ "crosstermion/color",
+ "humantime",
+ "unicode-width",
+]
+render-line-autoconfigure = ["atty"]
+render-line-crossterm = ["crosstermion/crossterm"]
+render-line-termion = ["crosstermion/termion"]
+render-tui = [
+ "tui",
+ "unicode-segmentation",
+ "unicode-width",
+ "crosstermion/input-async",
+ "tui-react",
+ "futures-lite",
+ "futures-core",
+ "async-io",
+ "humantime",
+]
+render-tui-crossterm = [
+ "crosstermion/tui-react-crossterm",
+ "crosstermion/input-async-crossterm",
+]
+render-tui-termion = ["crosstermion/tui-react-termion"]
+unit-bytes = ["bytesize"]
+unit-duration = ["compound_duration"]
+unit-human = ["human_format"]