summaryrefslogtreecommitdiffstats
path: root/vendor/r-efi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/r-efi/Cargo.toml
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/r-efi/Cargo.toml')
-rw-r--r--vendor/r-efi/Cargo.toml71
1 files changed, 71 insertions, 0 deletions
diff --git a/vendor/r-efi/Cargo.toml b/vendor/r-efi/Cargo.toml
new file mode 100644
index 000000000..5aac4541c
--- /dev/null
+++ b/vendor/r-efi/Cargo.toml
@@ -0,0 +1,71 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "r-efi"
+version = "4.2.0"
+authors = [
+ "David Rheinsberg <david.rheinsberg@gmail.com>",
+ "Tom Gundersen <teg@jklm.no>",
+]
+description = "UEFI Reference Specification Protocol Constants and Definitions"
+homepage = "https://github.com/r-efi/r-efi/wiki"
+readme = "README.md"
+keywords = [
+ "efi",
+ "uefi",
+ "boot",
+ "firmware",
+ "specification",
+]
+categories = [
+ "embedded",
+ "hardware-support",
+ "no-std",
+ "os",
+]
+license = "MIT OR Apache-2.0 OR LGPL-2.1-or-later"
+repository = "https://github.com/r-efi/r-efi"
+
+[[example]]
+name = "freestanding"
+required-features = ["native"]
+
+[[example]]
+name = "gop-query"
+required-features = ["native"]
+
+[[example]]
+name = "hello-world"
+required-features = ["native"]
+
+[[example]]
+name = "uefi-cross-compile"
+required-features = ["native"]
+
+[dependencies.compiler_builtins]
+version = "0.1.0"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[features]
+efiapi = []
+examples = ["native"]
+native = []
+rustc-dep-of-std = [
+ "compiler_builtins/rustc-dep-of-std",
+ "core",
+]