summaryrefslogtreecommitdiffstats
path: root/vendor/rayon-core/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/rayon-core/Cargo.toml
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rayon-core/Cargo.toml')
-rw-r--r--vendor/rayon-core/Cargo.toml12
1 files changed, 5 insertions, 7 deletions
diff --git a/vendor/rayon-core/Cargo.toml b/vendor/rayon-core/Cargo.toml
index d41715e65..d40cd14fd 100644
--- a/vendor/rayon-core/Cargo.toml
+++ b/vendor/rayon-core/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.59"
+rust-version = "1.63"
name = "rayon-core"
-version = "1.11.0"
+version = "1.12.0"
authors = [
"Niko Matsakis <niko@alum.mit.edu>",
"Josh Stone <cuviper@gmail.com>",
@@ -58,8 +58,9 @@ path = "tests/simple_panic.rs"
name = "scoped_threadpool"
path = "tests/scoped_threadpool.rs"
-[dependencies.crossbeam-channel]
-version = "0.5.0"
+[[test]]
+name = "use_current_thread"
+path = "tests/use_current_thread.rs"
[dependencies.crossbeam-deque]
version = "0.8.1"
@@ -67,9 +68,6 @@ version = "0.8.1"
[dependencies.crossbeam-utils]
version = "0.8.0"
-[dependencies.num_cpus]
-version = "1.2"
-
[dev-dependencies.rand]
version = "0.8"