summaryrefslogtreecommitdiffstats
path: root/vendor/regex-automata/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/regex-automata/Cargo.toml
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/regex-automata/Cargo.toml')
-rw-r--r--vendor/regex-automata/Cargo.toml168
1 files changed, 131 insertions, 37 deletions
diff --git a/vendor/regex-automata/Cargo.toml b/vendor/regex-automata/Cargo.toml
index 153f11fb3..fe4949f0d 100644
--- a/vendor/regex-automata/Cargo.toml
+++ b/vendor/regex-automata/Cargo.toml
@@ -10,20 +10,15 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "regex-automata"
-version = "0.2.0"
-authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = [
- "/.github",
- "/scripts/*",
- "/regex-cli",
- "/regex-test",
+version = "0.3.8"
+authors = [
+ "The Rust Project Developers",
+ "Andrew Gallant <jamslam@gmail.com>",
]
autoexamples = false
-autotests = false
description = "Automata construction and matching using regular expressions."
-homepage = "https://github.com/BurntSushi/regex-automata"
documentation = "https://docs.rs/regex-automata"
readme = "README.md"
keywords = [
@@ -34,55 +29,154 @@ keywords = [
"nfa",
]
categories = ["text-processing"]
-license = "Unlicense/MIT"
-repository = "https://github.com/BurntSushi/regex-automata"
-resolver = "2"
-
-[profile.bench]
-debug = true
-
-[profile.dev]
-opt-level = 3
-debug = true
-
-[profile.release]
-debug = true
-
-[profile.test]
-opt-level = 3
-debug = true
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/regex/tree/master/regex-automata"
[lib]
bench = false
[[test]]
name = "integration"
-path = "tests/tests.rs"
+path = "tests/lib.rs"
-[dependencies.fst]
-version = "0.4.5"
+[dependencies.aho-corasick]
+version = "1.0.0"
optional = true
+default-features = false
[dependencies.log]
version = "0.4.14"
optional = true
[dependencies.memchr]
-version = "2.4.0"
+version = "2.6.0"
+optional = true
default-features = false
[dependencies.regex-syntax]
-version = "0.6.24"
+version = "0.7.4"
optional = true
+default-features = false
+
+[dev-dependencies.anyhow]
+version = "1.0.69"
+
+[dev-dependencies.bstr]
+version = "1.3.0"
+features = ["std"]
+default-features = false
+
+[dev-dependencies.doc-comment]
+version = "0.3.3"
+
+[dev-dependencies.env_logger]
+version = "0.9.3"
+features = [
+ "atty",
+ "humantime",
+ "termcolor",
+]
+default-features = false
+
+[dev-dependencies.quickcheck]
+version = "1.0.3"
+default-features = false
+
+[dev-dependencies.regex-test]
+version = "0.1.0"
[features]
-alloc = ["syntax"]
+alloc = []
default = [
"std",
+ "syntax",
+ "perf",
+ "unicode",
+ "meta",
+ "nfa",
+ "dfa",
+ "hybrid",
+]
+dfa = [
+ "dfa-build",
+ "dfa-search",
+ "dfa-onepass",
+]
+dfa-build = [
+ "nfa-thompson",
+ "dfa-search",
+]
+dfa-onepass = ["nfa-thompson"]
+dfa-search = []
+hybrid = [
"alloc",
+ "nfa-thompson",
+]
+internal-instrument = ["internal-instrument-pikevm"]
+internal-instrument-pikevm = [
+ "logging",
+ "std",
+]
+logging = [
+ "dep:log",
+ "aho-corasick?/logging",
+ "memchr?/logging",
+]
+meta = [
"syntax",
+ "nfa-pikevm",
+]
+nfa = [
+ "nfa-thompson",
+ "nfa-pikevm",
+ "nfa-backtrack",
+]
+nfa-backtrack = ["nfa-thompson"]
+nfa-pikevm = ["nfa-thompson"]
+nfa-thompson = ["alloc"]
+perf = [
+ "perf-inline",
+ "perf-literal",
+]
+perf-inline = []
+perf-literal = [
+ "perf-literal-substring",
+ "perf-literal-multisubstring",
+]
+perf-literal-multisubstring = [
+ "std",
+ "dep:aho-corasick",
+]
+perf-literal-substring = [
+ "aho-corasick?/perf-literal",
+ "dep:memchr",
+]
+std = [
+ "regex-syntax?/std",
+ "memchr?/std",
+ "aho-corasick?/std",
+ "alloc",
+]
+syntax = [
+ "dep:regex-syntax",
+ "alloc",
+]
+unicode = [
+ "unicode-age",
+ "unicode-bool",
+ "unicode-case",
+ "unicode-gencat",
+ "unicode-perl",
+ "unicode-script",
+ "unicode-segment",
+ "unicode-word-boundary",
+ "regex-syntax?/unicode",
]
-logging = ["log"]
-std = []
-syntax = ["regex-syntax"]
-transducer = ["fst"]
+unicode-age = ["regex-syntax?/unicode-age"]
+unicode-bool = ["regex-syntax?/unicode-bool"]
+unicode-case = ["regex-syntax?/unicode-case"]
+unicode-gencat = ["regex-syntax?/unicode-gencat"]
+unicode-perl = ["regex-syntax?/unicode-perl"]
+unicode-script = ["regex-syntax?/unicode-script"]
+unicode-segment = ["regex-syntax?/unicode-segment"]
+unicode-word-boundary = []