summaryrefslogtreecommitdiffstats
path: root/vendor/rfc6979/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/rfc6979/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rfc6979/Cargo.toml')
-rw-r--r--vendor/rfc6979/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/vendor/rfc6979/Cargo.toml b/vendor/rfc6979/Cargo.toml
new file mode 100644
index 000000000..7ff912e2f
--- /dev/null
+++ b/vendor/rfc6979/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57"
+name = "rfc6979"
+version = "0.3.1"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of RFC6979: Deterministic Usage of the
+Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA)
+"""
+readme = "README.md"
+keywords = [
+ "dsa",
+ "ecdsa",
+ "signature",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/signatures/tree/master/rfc6979"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.crypto-bigint]
+version = "0.4"
+features = [
+ "generic-array",
+ "zeroize",
+]
+default-features = false
+
+[dependencies.hmac]
+version = "0.12"
+features = ["reset"]
+default-features = false
+
+[dependencies.zeroize]
+version = "1"
+default-features = false
+
+[dev-dependencies.sha2]
+version = "0.10"