summaryrefslogtreecommitdiffstats
path: root/vendor/rusty-fork/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/rusty-fork/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rusty-fork/Cargo.toml')
-rw-r--r--vendor/rusty-fork/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/vendor/rusty-fork/Cargo.toml b/vendor/rusty-fork/Cargo.toml
new file mode 100644
index 000000000..987639ef2
--- /dev/null
+++ b/vendor/rusty-fork/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rusty-fork"
+version = "0.3.0"
+authors = ["Jason Lingle"]
+exclude = ["/gen-readme.sh", "/readme-*.md"]
+description = "Cross-platform library for running Rust tests in sub-processes using a\nfork-like interface.\n"
+documentation = "https://docs.rs/rusty-fork"
+readme = "README.md"
+keywords = ["testing", "process", "fork"]
+categories = ["development-tools::testing"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/altsysrq/rusty-fork"
+[dependencies.fnv]
+version = "1.0"
+
+[dependencies.quick-error]
+version = "1.2"
+
+[dependencies.tempfile]
+version = "3.0"
+
+[dependencies.wait-timeout]
+version = "0.2"
+optional = true
+
+[dev-dependencies]
+
+[features]
+default = ["timeout"]
+timeout = ["wait-timeout"]
+[badges.travis-ci]
+repository = "AltSysrq/rusty-fork"