summaryrefslogtreecommitdiffstats
path: root/vendor/ruzstd/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/ruzstd/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/ruzstd/Cargo.toml')
-rw-r--r--vendor/ruzstd/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/vendor/ruzstd/Cargo.toml b/vendor/ruzstd/Cargo.toml
new file mode 100644
index 000000000..b80aad59c
--- /dev/null
+++ b/vendor/ruzstd/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "ruzstd"
+version = "0.3.1"
+authors = ["Moritz Borcherding <moritz.borcherding@web.de>"]
+exclude = [
+ "decodecorpus_files/*",
+ "dict_tests/*",
+ "fuzz_decodecorpus/*",
+]
+description = "A decoder for the zstd compression format"
+homepage = "https://github.com/KillingSpark/zstd-rs"
+readme = "Readme.md"
+license = "MIT"
+repository = "https://github.com/KillingSpark/zstd-rs"
+
+[[bench]]
+name = "reversedbitreader_bench"
+harness = false
+
+[dependencies.byteorder]
+version = "1.4"
+
+[dependencies.thiserror]
+version = "1"
+
+[dependencies.twox-hash]
+version = "1.6"
+default-features = false
+
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.rand]
+version = "0.8.5"