summaryrefslogtreecommitdiffstats
path: root/vendor/ruzstd/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /vendor/ruzstd/Cargo.toml
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/ruzstd/Cargo.toml')
-rw-r--r--vendor/ruzstd/Cargo.toml19
1 files changed, 17 insertions, 2 deletions
diff --git a/vendor/ruzstd/Cargo.toml b/vendor/ruzstd/Cargo.toml
index b80aad59c..4c04c33ae 100644
--- a/vendor/ruzstd/Cargo.toml
+++ b/vendor/ruzstd/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "ruzstd"
-version = "0.3.1"
+version = "0.4.0"
authors = ["Moritz Borcherding <moritz.borcherding@web.de>"]
exclude = [
"decodecorpus_files/*",
@@ -25,15 +25,26 @@ readme = "Readme.md"
license = "MIT"
repository = "https://github.com/KillingSpark/zstd-rs"
+[[bin]]
+name = "zstd"
+required-features = ["std"]
+
+[[bin]]
+name = "zstd_stream"
+required-features = ["std"]
+
[[bench]]
name = "reversedbitreader_bench"
harness = false
[dependencies.byteorder]
version = "1.4"
+default-features = false
[dependencies.thiserror]
-version = "1"
+version = "1.0.38"
+default-features = false
+package = "thiserror-core"
[dependencies.twox-hash]
version = "1.6"
@@ -44,3 +55,7 @@ version = "0.3"
[dev-dependencies.rand]
version = "0.8.5"
+
+[features]
+default = ["std"]
+std = ["thiserror/std"]