summaryrefslogtreecommitdiffstats
path: root/vendor/serde_ignored/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/serde_ignored/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/serde_ignored/Cargo.toml')
-rw-r--r--vendor/serde_ignored/Cargo.toml30
1 files changed, 22 insertions, 8 deletions
diff --git a/vendor/serde_ignored/Cargo.toml b/vendor/serde_ignored/Cargo.toml
index 9b93fc748..bebf48bfc 100644
--- a/vendor/serde_ignored/Cargo.toml
+++ b/vendor/serde_ignored/Cargo.toml
@@ -3,28 +3,42 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.36"
name = "serde_ignored"
-version = "0.1.2"
+version = "0.1.7"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Find out about keys that are ignored when deserializing data"
readme = "README.md"
-keywords = ["serde"]
-categories = ["encoding"]
+keywords = [
+ "serde",
+ "serialization",
+]
+categories = [
+ "encoding",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/serde-ignored"
+
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
[dependencies.serde]
version = "1.0"
+features = ["alloc"]
+default-features = false
+
[dev-dependencies.serde_derive]
version = "1.0"