summaryrefslogtreecommitdiffstats
path: root/vendor/sha1_smol/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/sha1_smol/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/sha1_smol/Cargo.toml')
-rw-r--r--vendor/sha1_smol/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/vendor/sha1_smol/Cargo.toml b/vendor/sha1_smol/Cargo.toml
new file mode 100644
index 000000000..5441fed79
--- /dev/null
+++ b/vendor/sha1_smol/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "sha1_smol"
+version = "1.0.0"
+authors = ["Armin Ronacher <armin.ronacher@active-4.com>"]
+description = "Minimal dependency free implementation of SHA1 for Rust."
+keywords = ["sha1"]
+license = "BSD-3-Clause"
+repository = "https://github.com/mitsuhiko/sha1-smol"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.serde]
+version = "1.0"
+optional = true
+[dev-dependencies.openssl]
+version = "0.10"
+
+[dev-dependencies.rand]
+version = "0.4"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+std = []