summaryrefslogtreecommitdiffstats
path: root/vendor/sha1_smol/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/sha1_smol/Makefile
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/sha1_smol/Makefile')
-rw-r--r--vendor/sha1_smol/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/vendor/sha1_smol/Makefile b/vendor/sha1_smol/Makefile
new file mode 100644
index 000000000..256f7fb86
--- /dev/null
+++ b/vendor/sha1_smol/Makefile
@@ -0,0 +1,18 @@
+build:
+ @cargo build
+
+watch:
+ @cargo watch
+
+watch-docs:
+ @cargo watch build "doc --no-deps"
+
+test:
+ @cargo test --features=serde
+ @cargo test --features=std
+ @cargo test
+
+docs: build
+ @cargo doc --no-deps
+
+.PHONY: build test docs