summaryrefslogtreecommitdiffstats
path: root/vendor/similar/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/similar/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/similar/Cargo.toml')
-rw-r--r--vendor/similar/Cargo.toml86
1 files changed, 86 insertions, 0 deletions
diff --git a/vendor/similar/Cargo.toml b/vendor/similar/Cargo.toml
new file mode 100644
index 000000000..5f94e2f04
--- /dev/null
+++ b/vendor/similar/Cargo.toml
@@ -0,0 +1,86 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "similar"
+version = "2.1.0"
+authors = ["Armin Ronacher <armin.ronacher@active-4.com>", "Pierre-Étienne Meunier <pe@pijul.org>", "Brandon Williams <bwilliams.eng@gmail.com>"]
+exclude = ["assets/*"]
+description = "A diff library for Rust"
+readme = "README.md"
+keywords = ["diff", "difference", "patience", "compare", "changes"]
+license = "Apache-2.0"
+repository = "https://github.com/mitsuhiko/similar"
+[package.metadata.docs.rs]
+all-features = true
+[profile.release]
+debug = true
+
+[[example]]
+name = "patience"
+required-features = ["text", "inline"]
+
+[[example]]
+name = "terminal"
+required-features = ["text"]
+
+[[example]]
+name = "terminal-inline"
+required-features = ["text", "inline", "bytes"]
+
+[[example]]
+name = "original-slices"
+required-features = ["text"]
+
+[[example]]
+name = "udiff"
+required-features = ["text", "bytes"]
+
+[[example]]
+name = "close-matches"
+required-features = ["text"]
+
+[[example]]
+name = "large"
+required-features = ["text"]
+
+[[example]]
+name = "serde"
+required-features = ["text", "serde"]
+[dependencies.bstr]
+version = "0.2.14"
+optional = true
+default-features = false
+
+[dependencies.serde]
+version = "1.0.130"
+features = ["derive"]
+optional = true
+
+[dependencies.unicode-segmentation]
+version = "1.7.1"
+optional = true
+[dev-dependencies.console]
+version = "0.14.0"
+
+[dev-dependencies.insta]
+version = "1.6.2"
+
+[dev-dependencies.serde_json]
+version = "1.0.68"
+
+[features]
+bytes = ["bstr", "text"]
+default = ["text"]
+inline = ["text"]
+text = []
+unicode = ["text", "unicode-segmentation", "bstr/unicode"]