summaryrefslogtreecommitdiffstats
path: root/vendor/similar/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/similar/Makefile
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/similar/Makefile')
-rw-r--r--vendor/similar/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/vendor/similar/Makefile b/vendor/similar/Makefile
new file mode 100644
index 000000000..af6e83179
--- /dev/null
+++ b/vendor/similar/Makefile
@@ -0,0 +1,27 @@
+all: test
+
+build:
+ @cargo build --all-features
+
+doc:
+ @cargo doc --all-features
+
+test:
+ @cargo test
+ @cargo test --all-features
+ @cargo test --no-default-features
+ @cargo test --no-default-features --features bytes
+
+format:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all
+
+format-check:
+ @rustup component add rustfmt 2> /dev/null
+ @cargo fmt --all -- --check
+
+lint:
+ @rustup component add clippy 2> /dev/null
+ @cargo clippy
+
+.PHONY: all doc test format format-check lint