summaryrefslogtreecommitdiffstats
path: root/vendor/siphasher/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/siphasher/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/siphasher/Cargo.toml')
-rw-r--r--vendor/siphasher/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/vendor/siphasher/Cargo.toml b/vendor/siphasher/Cargo.toml
new file mode 100644
index 000000000..4fcde0377
--- /dev/null
+++ b/vendor/siphasher/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "siphasher"
+version = "0.3.3"
+authors = ["Frank Denis <github@pureftpd.org>"]
+description = "SipHash-2-4, SipHash-1-3 and 128-bit variants in pure Rust"
+homepage = "https://docs.rs/siphasher"
+documentation = "https://docs.rs/siphasher"
+readme = "README.md"
+keywords = ["crypto", "hash", "siphash"]
+categories = ["algorithms", "cryptography"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jedisct1/rust-siphash"
+[profile.release]
+opt-level = 3
+lto = true
+panic = "abort"
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+default = ["std"]
+serde_no_std = ["serde/alloc"]
+serde_std = ["std", "serde/std"]
+std = []
+[badges.travis-ci]
+repository = "jedisct1/rust-siphash"