summaryrefslogtreecommitdiffstats
path: root/vendor/siphasher/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/siphasher/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/siphasher/Cargo.toml')
-rw-r--r--vendor/siphasher/Cargo.toml32
1 files changed, 23 insertions, 9 deletions
diff --git a/vendor/siphasher/Cargo.toml b/vendor/siphasher/Cargo.toml
index 4fcde0377..8ad6e50d7 100644
--- a/vendor/siphasher/Cargo.toml
+++ b/vendor/siphasher/Cargo.toml
@@ -3,40 +3,54 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
name = "siphasher"
-version = "0.3.3"
+version = "0.3.10"
authors = ["Frank Denis <github@pureftpd.org>"]
description = "SipHash-2-4, SipHash-1-3 and 128-bit variants in pure Rust"
homepage = "https://docs.rs/siphasher"
documentation = "https://docs.rs/siphasher"
readme = "README.md"
-keywords = ["crypto", "hash", "siphash"]
-categories = ["algorithms", "cryptography"]
+keywords = [
+ "crypto",
+ "hash",
+ "siphash",
+]
+categories = [
+ "algorithms",
+ "cryptography",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/jedisct1/rust-siphash"
+
[profile.release]
opt-level = 3
lto = true
panic = "abort"
+
[dependencies.serde]
version = "1.0"
features = ["derive"]
optional = true
+
[dev-dependencies.serde_json]
version = "1.0"
[features]
default = ["std"]
serde_no_std = ["serde/alloc"]
-serde_std = ["std", "serde/std"]
+serde_std = [
+ "std",
+ "serde/std",
+]
std = []
+
[badges.travis-ci]
repository = "jedisct1/rust-siphash"