summaryrefslogtreecommitdiffstats
path: root/vendor/snapbox-macros
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/snapbox-macros
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/snapbox-macros')
-rw-r--r--vendor/snapbox-macros/.cargo-checksum.json2
-rw-r--r--vendor/snapbox-macros/Cargo.toml6
-rw-r--r--vendor/snapbox-macros/LICENSE-MIT2
-rw-r--r--vendor/snapbox-macros/src/lib.rs2
4 files changed, 7 insertions, 5 deletions
diff --git a/vendor/snapbox-macros/.cargo-checksum.json b/vendor/snapbox-macros/.cargo-checksum.json
index a9118bf68..5c177254c 100644
--- a/vendor/snapbox-macros/.cargo-checksum.json
+++ b/vendor/snapbox-macros/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"ee3357770fe9ae36457904677e4a9de2b6a1b31a15a2502280930463d599b387","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"ec676bb3166bb11d74f8fbd05d77d8ab7449950176ccc969ffcdb151a5da7fd7","README.md":"4fc2a7458a321d6a037e3c63c5b0c79679bb5cf430b3e1107b05e60c108a8bdd","src/lib.rs":"c17a016d80eb9538f4f7191cd040c025afbd6a9f4f664e44b2f02f53cd177722"},"package":"eaaf09df9f0eeae82be96290918520214530e738a7fe5a351b0f24cf77c0ca31"} \ No newline at end of file
+{"files":{"Cargo.toml":"ff672d1c08b91ef9c82b5f9111e74b4165ec08cf052fd3f433db0288f15a0ff3","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"6efb0476a1cc085077ed49357026d8c173bf33017278ef440f222fb9cbcb66e6","README.md":"4fc2a7458a321d6a037e3c63c5b0c79679bb5cf430b3e1107b05e60c108a8bdd","src/lib.rs":"928bcefee6bd6450647747f38c541276617ada57aed0ed9dc3f9a7967c2f4a1b"},"package":"ed1559baff8a696add3322b9be3e940d433e7bb4e38d79017205fd37ff28b28e"} \ No newline at end of file
diff --git a/vendor/snapbox-macros/Cargo.toml b/vendor/snapbox-macros/Cargo.toml
index f32573d8e..398ecfdde 100644
--- a/vendor/snapbox-macros/Cargo.toml
+++ b/vendor/snapbox-macros/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.64.0"
+rust-version = "1.70.0"
name = "snapbox-macros"
-version = "0.3.4"
+version = "0.3.6"
include = [
"build.rs",
"src/**/*",
@@ -41,7 +41,7 @@ repository = "https://github.com/assert-rs/trycmd/"
all-features = true
[dependencies.anstream]
-version = "0.3.0"
+version = "0.6.0"
optional = true
[features]
diff --git a/vendor/snapbox-macros/LICENSE-MIT b/vendor/snapbox-macros/LICENSE-MIT
index 6338906f7..a2d01088b 100644
--- a/vendor/snapbox-macros/LICENSE-MIT
+++ b/vendor/snapbox-macros/LICENSE-MIT
@@ -1,4 +1,4 @@
-Copyright (c) 2021 Individual contributors
+Copyright (c) Individual contributors
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
diff --git a/vendor/snapbox-macros/src/lib.rs b/vendor/snapbox-macros/src/lib.rs
index a9e0461f8..1bc98f7bf 100644
--- a/vendor/snapbox-macros/src/lib.rs
+++ b/vendor/snapbox-macros/src/lib.rs
@@ -1,3 +1,5 @@
+#![cfg_attr(docsrs, feature(doc_auto_cfg))]
+
#[cfg(feature = "color")]
pub use anstream::eprint;
#[cfg(feature = "color")]