summaryrefslogtreecommitdiffstats
path: root/vendor/socket2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/socket2/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/socket2/Cargo.toml')
-rw-r--r--vendor/socket2/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/vendor/socket2/Cargo.toml b/vendor/socket2/Cargo.toml
new file mode 100644
index 000000000..521c43c2c
--- /dev/null
+++ b/vendor/socket2/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "socket2"
+version = "0.4.1"
+authors = ["Alex Crichton <alex@alexcrichton.com>", "Thomas de Zeeuw <thomasdezeeuw@gmail.com>"]
+include = ["Cargo.toml", "LICENSE-APACHE", "LICENSE-MIT", "README.md", "src/**/*.rs"]
+description = "Utilities for handling networking sockets with a maximal amount of configuration\npossible intended.\n"
+homepage = "https://github.com/rust-lang/socket2"
+documentation = "https://docs.rs/socket2"
+readme = "README.md"
+keywords = ["io", "socket", "network"]
+categories = ["api-bindings", "network-programming"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-lang/socket2"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+
+[package.metadata.playground]
+features = ["all"]
+
+[features]
+all = []
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.96"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.9"
+features = ["handleapi", "ws2ipdef", "ws2tcpip"]