summaryrefslogtreecommitdiffstats
path: root/vendor/supports-hyperlinks
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/supports-hyperlinks
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/supports-hyperlinks')
-rw-r--r--vendor/supports-hyperlinks/.cargo-checksum.json1
-rw-r--r--vendor/supports-hyperlinks/CHANGELOG.md49
-rw-r--r--vendor/supports-hyperlinks/Cargo.toml25
-rw-r--r--vendor/supports-hyperlinks/LICENSE229
-rw-r--r--vendor/supports-hyperlinks/Makefile.toml11
-rw-r--r--vendor/supports-hyperlinks/README.md28
-rw-r--r--vendor/supports-hyperlinks/cliff.toml62
-rw-r--r--vendor/supports-hyperlinks/src/lib.rs67
8 files changed, 472 insertions, 0 deletions
diff --git a/vendor/supports-hyperlinks/.cargo-checksum.json b/vendor/supports-hyperlinks/.cargo-checksum.json
new file mode 100644
index 000000000..dfa1fedd6
--- /dev/null
+++ b/vendor/supports-hyperlinks/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"2571110c10802a3d7b0dd592a86f8b3b60d1df1d9c3d19735040a07b5f4d9695","Cargo.toml":"a559b1c95bd6fdafbe850a9c3113b08731692461d37e011159cf4e1263612dd0","LICENSE":"610432849befa0e875d601d044e7e5441eb86c83d052681b23aef357b2a0b928","Makefile.toml":"b780b6410cd4acf5a249c2b553e6f3e5ce95f0d4e156c1d4a41e3b1abbc39604","README.md":"eb9acbf4aad0922414f3a9309ef103b9a6b067acdd677ba20c43ba6f666e6a37","cliff.toml":"9ea8157ea9b663dd99b4a48a686b060637fe18c8fdd82c6dd22a76a8e45f3914","src/lib.rs":"b0493dcf3e613f0e3344a71bef843025c36cd6026c909efaf9d13744849274da"},"package":"f84231692eb0d4d41e4cdd0cabfdd2e6cd9e255e65f80c9aa7c98dd502b4233d"} \ No newline at end of file
diff --git a/vendor/supports-hyperlinks/CHANGELOG.md b/vendor/supports-hyperlinks/CHANGELOG.md
new file mode 100644
index 000000000..d0f92a236
--- /dev/null
+++ b/vendor/supports-hyperlinks/CHANGELOG.md
@@ -0,0 +1,49 @@
+# `supports-hyperlinks` Release Changelog
+
+<a name="2.1.0"></a>
+## 2.1.0 (2023-04-18)
+
+### Features
+
+* **terms:** add support for a couple more terminals ([0a7728c5](https://github.com/zkat/supports-hyperlinks/commit/0a7728c5b2d67a7bb52d497c2ce567a2d496d9db))
+
+### Miscellaneous Tasks
+
+* **edition:** bump edition to 2021 ([5cd860b1](https://github.com/zkat/supports-hyperlinks/commit/5cd860b1c36ebc0820ad66bf5736609f83365830))
+
+<a name="2.0.0"></a>
+## 2.0.0 (2023-03-13)
+
+This semver-major release is just for switching away from `atty` due to
+soundness and maintenance concerns. See [this issue in `supports-color` for
+more details](https://github.com/zkat/supports-color/issues/9)
+
+### Features
+
+* **tty:** Switch from `atty` to `is-terminal` (#3) ([a321f355](https://github.com/zkat/supports-hyperlinks/commit/a321f35558f9dcb47d225c25e74d8c0d911bbaa8))
+ * **BREAKING CHANGE**: the exported `Stream` enum is no longer an `atty` type, and this crate no longer accepts `atty` types as input.
+
+<a name="1.2.0"></a>
+## 1.2.0 (2021-09-16)
+
+### Bug Fixes
+
+* **conditions:** allow fallthrough when nested checks are false ([3aa5ffbb](https://github.com/zkat/supports-hyperlinks/commit/3aa5ffbba5bd1c902864f4fa4f3f9bbd0c0bcb0b))
+
+### Features
+
+* **force:** add support for forcing hyperlinks ([96d75a7c](https://github.com/zkat/supports-hyperlinks/commit/96d75a7ce7bac6a6fd3f7630eb0579750d4ebb82))
+
+<a name="1.1.0"></a>
+## 1.1.0 (2021-09-11)
+
+### Features
+
+* **on:** add atty and on() function for ease of use ([bf17421f](https://github.com/zkat/supports-hyperlinks/commit/bf17421f14791ab6308d209c5c0eda72081bd664))
+
+<a name="1.0.0"></a>
+## 1.0.0 (2021-09-11)
+
+### Features
+
+* **api:** initial commit ([4eb64a5b](https://github.com/zkat/supports-hyperlinks/commit/4eb64a5b67ff913ce269077e01f430d45a5aa40d))
diff --git a/vendor/supports-hyperlinks/Cargo.toml b/vendor/supports-hyperlinks/Cargo.toml
new file mode 100644
index 000000000..2cfac1ba7
--- /dev/null
+++ b/vendor/supports-hyperlinks/Cargo.toml
@@ -0,0 +1,25 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "supports-hyperlinks"
+version = "2.1.0"
+authors = ["Kat Marchán <kzm@zkat.tech>"]
+description = "Detects whether a terminal supports rendering hyperlinks."
+documentation = "https://docs.rs/supports-hyperlinks"
+readme = "README.md"
+categories = ["terminal"]
+license = "Apache-2.0"
+repository = "https://github.com/zkat/supports-hyperlinks"
+
+[dependencies.is-terminal]
+version = "0.4.0"
diff --git a/vendor/supports-hyperlinks/LICENSE b/vendor/supports-hyperlinks/LICENSE
new file mode 100644
index 000000000..10fa5cc56
--- /dev/null
+++ b/vendor/supports-hyperlinks/LICENSE
@@ -0,0 +1,229 @@
+Apache License
+
+Version 2.0, January 2004
+
+http://www.apache.org/licenses/ TERMS
+AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+
+
+
+ "License" shall mean the terms and conditions for use, reproduction, and
+distribution as defined by Sections 1 through 9 of this document.
+
+
+
+
+"Licensor" shall mean the copyright owner or entity authorized by the copyright
+owner that is granting the License.
+
+
+
+ "Legal Entity" shall mean the
+union of the acting entity and all other entities that control, are controlled
+by, or are under common control with that entity. For the purposes of this
+definition, "control" means (i) the power, direct or indirect, to cause the
+direction or management of such entity, whether by contract or otherwise, or (ii)
+ownership of fifty percent (50%) or more of the outstanding shares, or (iii)
+beneficial ownership of such entity.
+
+
+
+ "You" (or "Your") shall mean
+an individual or Legal Entity exercising permissions granted by this License.
+
+
+
+
+ "Source" form shall mean the preferred form for making modifications,
+including but not limited to software source code, documentation source, and
+configuration files.
+
+
+
+ "Object" form shall mean any form resulting
+from mechanical transformation or translation of a Source form, including but not
+limited to compiled object code, generated documentation, and conversions to
+other media types.
+
+
+
+ "Work" shall mean the work of authorship,
+whether in Source or Object form, made available under the License, as indicated
+by a copyright notice that is included in or attached to the work (an example is
+provided in the Appendix below).
+
+
+
+ "Derivative Works" shall mean any
+work, whether in Source or Object form, that is based on (or derived from) the
+Work and for which the editorial revisions, annotations, elaborations, or other
+modifications represent, as a whole, an original work of authorship. For the
+purposes of this License, Derivative Works shall not include works that remain
+separable from, or merely link (or bind by name) to the interfaces of, the Work
+and Derivative Works thereof.
+
+
+
+ "Contribution" shall mean any work
+of authorship, including the original version of the Work and any modifications
+or additions to that Work or Derivative Works thereof, that is intentionally
+submitted to Licensor for inclusion in the Work by the copyright owner or by an
+individual or Legal Entity authorized to submit on behalf of the copyright owner.
+For the purposes of this definition, "submitted" means any form of electronic,
+verbal, or written communication sent to the Licensor or its representatives,
+including but not limited to communication on electronic mailing lists, source
+code control systems, and issue tracking systems that are managed by, or on
+behalf of, the Licensor for the purpose of discussing and improving the Work, but
+excluding communication that is conspicuously marked or otherwise designated in
+writing by the copyright owner as "Not a Contribution."
+
+
+
+
+"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of
+whom a Contribution has been received by Licensor and subsequently incorporated
+within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and
+conditions of this License, each Contributor hereby grants to You a perpetual,
+worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license
+to reproduce, prepare Derivative Works of, publicly display, publicly perform,
+sublicense, and distribute the Work and such Derivative Works in Source or Object
+form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of this
+License, each Contributor hereby grants to You a perpetual, worldwide,
+non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this
+section) patent license to make, have made, use, offer to sell, sell, import, and
+otherwise transfer the Work, where such license applies only to those patent
+claims licensable by such Contributor that are necessarily infringed by their
+Contribution(s) alone or by combination of their Contribution(s) with the Work to
+which such Contribution(s) was submitted. If You institute patent litigation
+against any entity (including a cross-claim or counterclaim in a lawsuit)
+alleging that the Work or a Contribution incorporated within the Work constitutes
+direct or contributory patent infringement, then any patent licenses granted to
+You under this License for that Work shall terminate as of the date such
+litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute
+copies of the Work or Derivative Works thereof in any medium, with or without
+modifications, and in Source or Object form, provided that You meet the following
+conditions:
+
+ (a) You must give any other recipients of the Work or
+Derivative Works a copy of this License; and
+
+ (b) You must cause any
+modified files to carry prominent notices stating that You changed the files;
+and
+
+ (c) You must retain, in the Source form of any Derivative Works that
+You distribute, all copyright, patent, trademark, and attribution notices from
+the Source form of the Work, excluding those notices that do not pertain to any
+part of the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text
+file as part of its distribution, then any Derivative Works that You distribute
+must include a readable copy of the attribution notices contained within such
+NOTICE file, excluding those notices that do not pertain to any part of the
+Derivative Works, in at least one of the following places: within a NOTICE text
+file distributed as part of the Derivative Works; within the Source form or
+documentation, if provided along with the Derivative Works; or, within a display
+generated by the Derivative Works, if and wherever such third-party notices
+normally appear. The contents of the NOTICE file are for informational purposes
+only and do not modify the License. You may add Your own attribution notices
+within Derivative Works that You distribute, alongside or as an addendum to the
+NOTICE text from the Work, provided that such additional attribution notices
+cannot be construed as modifying the License.
+
+ You may add Your own
+copyright statement to Your modifications and may provide additional or different
+license terms and conditions for use, reproduction, or distribution of Your
+modifications, or for any such Derivative Works as a whole, provided Your use,
+reproduction, and distribution of the Work otherwise complies with the conditions
+stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly
+state otherwise, any Contribution intentionally submitted for inclusion in the
+Work by You to the Licensor shall be under the terms and conditions of this
+License, without any additional terms or conditions. Notwithstanding the above,
+nothing herein shall supersede or modify the terms of any separate license
+agreement you may have executed with Licensor regarding such Contributions.
+
+
+6. Trademarks. This License does not grant permission to use the trade names,
+trademarks, service marks, or product names of the Licensor, except as required
+for reasonable and customary use in describing the origin of the Work and
+reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless
+required by applicable law or agreed to in writing, Licensor provides the Work
+(and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT
+WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including,
+without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT,
+MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible
+for determining the appropriateness of using or redistributing the Work and
+assume any risks associated with Your exercise of permissions under this
+License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+whether in tort (including negligence), contract, or otherwise, unless required
+by applicable law (such as deliberate and grossly negligent acts) or agreed to in
+writing, shall any Contributor be liable to You for damages, including any
+direct, indirect, special, incidental, or consequential damages of any character
+arising as a result of this License or out of the use or inability to use the
+Work (including but not limited to damages for loss of goodwill, work stoppage,
+computer failure or malfunction, or any and all other commercial damages or
+losses), even if such Contributor has been advised of the possibility of such
+damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+the Work or Derivative Works thereof, You may choose to offer, and charge a fee
+for, acceptance of support, warranty, indemnity, or other liability obligations
+and/or rights consistent with this License. However, in accepting such
+obligations, You may act only on Your own behalf and on Your sole responsibility,
+not on behalf of any other Contributor, and only if You agree to indemnify,
+defend, and hold each Contributor harmless for any liability incurred by, or
+claims asserted against, such Contributor by reason of your accepting any such
+warranty or additional liability. END OF TERMS AND CONDITIONS
+
+APPENDIX: How to
+apply the Apache License to your work.
+
+To apply the Apache License to your work,
+attach the following boilerplate notice, with the fields enclosed by brackets
+"[]" replaced with your own identifying information. (Don't include the
+brackets!) The text should be enclosed in the appropriate comment syntax for the
+file format. We also recommend that a file or class name and description of
+purpose be included on the same "printed page" as the copyright notice for easier
+identification within third-party archives.
+
+Copyright [yyyy] Kat
+Marchán
+
+Licensed under the Apache License, Version 2.0 (the "License");
+
+you may
+not use this file except in compliance with the License.
+
+You may obtain a copy
+of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by
+applicable law or agreed to in writing, software
+
+distributed under the License
+is distributed on an "AS IS" BASIS,
+
+WITHOUT WARRANTIES OR CONDITIONS OF ANY
+KIND, either express or implied.
+
+See the License for the specific language
+governing permissions and
+
+limitations under the License. \ No newline at end of file
diff --git a/vendor/supports-hyperlinks/Makefile.toml b/vendor/supports-hyperlinks/Makefile.toml
new file mode 100644
index 000000000..70e794325
--- /dev/null
+++ b/vendor/supports-hyperlinks/Makefile.toml
@@ -0,0 +1,11 @@
+[tasks.changelog]
+workspace=false
+install_crate="git-cliff"
+command = "git-cliff"
+args = ["--prepend", "CHANGELOG.md", "-u", "--tag", "${@}"]
+
+[tasks.release]
+workspace=false
+install_crate="cargo-release"
+command = "cargo"
+args = ["release", "--workspace", "${@}"]
diff --git a/vendor/supports-hyperlinks/README.md b/vendor/supports-hyperlinks/README.md
new file mode 100644
index 000000000..f01ef92d6
--- /dev/null
+++ b/vendor/supports-hyperlinks/README.md
@@ -0,0 +1,28 @@
+Detects whether the current terminal supports [hyperlinks in terminal
+emulators](https://gist.github.com/egmontkob/eb114294efbcd5adb1944c9f3cb5feda).
+
+It tries to detect and support all known terminals and terminal families that
+support this. If a declaration is wrong, missing, or could be improved, please
+send a PR!
+
+## Example
+
+The API is super simple!
+
+```rust
+use supports_hyperlinks::Stream;
+
+if supports_hyperlinks::on(Stream::Stdout) {
+ println!("This terminal supports hyperlinks on stdout");
+} else {
+ println!("No hyperlinks, please");
+}
+```
+
+And that's it!
+
+## Forcing hyperlinks in tools that use `supports-hyperlinks`
+
+You may set the `FORCE_HYPERLINK` environment variable to force
+`supports-hyperlinks` to return true for its checks. If the value is `0`, this
+will force it to be _false_, instead.
diff --git a/vendor/supports-hyperlinks/cliff.toml b/vendor/supports-hyperlinks/cliff.toml
new file mode 100644
index 000000000..1338df94b
--- /dev/null
+++ b/vendor/supports-hyperlinks/cliff.toml
@@ -0,0 +1,62 @@
+# configuration file for git-cliff (0.1.0)
+
+[changelog]
+# changelog header
+header = """
+# `supports-hyperlinks` Release Changelog
+
+"""
+
+# template for the changelog body
+# https://tera.netlify.app/docs/#introduction
+body = """
+{% if version %}\
+<a name="{{ version }}"></a>
+## {{ version | replace(from="v", to="") }} ({{ timestamp | date(format="%Y-%m-%d") }})
+{% else %}\
+## Unreleased
+{% endif %}\
+{% for group, commits in commits | filter(attribute="scope") | group_by(attribute="group") %}
+### {{ group | upper_first }}
+{% for commit in commits %}
+{% if commit.scope %}\
+* **{{ commit.scope }}:** {{ commit.message }} ([{{ commit.id | truncate(length=8, end="") }}](https://github.com/zkat/supports-hyperlinks/commit/{{ commit.id }}))
+{%- if commit.breaking %}
+ * **BREAKING CHANGE**: {{ commit.breaking_description }}
+{%- endif %}\
+{% endif %}\
+{% endfor %}
+{% endfor %}
+"""
+
+# remove the leading and trailing whitespace from the template
+trim = false
+
+# changelog footer
+# footer = """
+# <!-- generated by git-cliff -->
+# """
+
+[git]
+# allow only conventional commits
+# https://www.conventionalcommits.org
+conventional_commits = true
+# regex for parsing and grouping commits
+commit_parsers = [
+ { message = "^feat*", group = "Features"},
+ { message = "^fix*", group = "Bug Fixes"},
+ { message = "^doc*", group = "Documentation"},
+ { message = "^perf*", group = "Performance"},
+ { message = "^refactor*", group = "Refactor"},
+ { message = "^style*", group = "Styling"},
+ { message = "^test*", group = "Testing"},
+ { message = "^chore\\(release\\): prepare for*", skip = true},
+ { message = "^chore*", group = "Miscellaneous Tasks"},
+ { body = ".*security", group = "Security"},
+]
+# filter out the commits that are not matched by commit parsers
+filter_commits = false
+# glob pattern for matching git tags
+# tag_pattern = "[0-9]*"
+# regex for skipping tags
+# skip_tags = "v0.1.0-beta.1"
diff --git a/vendor/supports-hyperlinks/src/lib.rs b/vendor/supports-hyperlinks/src/lib.rs
new file mode 100644
index 000000000..83290b211
--- /dev/null
+++ b/vendor/supports-hyperlinks/src/lib.rs
@@ -0,0 +1,67 @@
+#![doc = include_str!("../README.md")]
+
+/// possible stream sources
+#[derive(Clone, Copy, Debug)]
+pub enum Stream {
+ Stdout,
+ Stderr,
+}
+
+/// Returns true if the current terminal, detected through various environment
+/// variables, is known to support hyperlink rendering.
+pub fn supports_hyperlinks() -> bool {
+ // Hyperlinks can be forced through this env var.
+ if let Ok(arg) = std::env::var("FORCE_HYPERLINK") {
+ return arg.trim() != "0";
+ }
+
+ if std::env::var("DOMTERM").is_ok() {
+ // DomTerm
+ return true;
+ }
+
+ if let Ok(version) = std::env::var("VTE_VERSION") {
+ // VTE-based terminals above v0.50 (Gnome Terminal, Guake, ROXTerm, etc)
+ if version.parse().unwrap_or(0) >= 5000 {
+ return true;
+ }
+ }
+
+ if let Ok(program) = std::env::var("TERM_PROGRAM") {
+ if matches!(
+ &program[..],
+ "Hyper" | "iTerm.app" | "terminology" | "WezTerm" | "vscode"
+ ) {
+ return true;
+ }
+ }
+
+ if let Ok(term) = std::env::var("TERM") {
+ if matches!(&term[..], "xterm-kitty" | "alacritty" | "alacritty-direct") {
+ return true;
+ }
+ }
+
+ if let Ok(term) = std::env::var("COLORTERM") {
+ if matches!(&term[..], "xfce4-terminal") {
+ return true;
+ }
+ }
+
+ // Windows Terminal and Konsole
+ std::env::var("WT_SESSION").is_ok() || std::env::var("KONSOLE_VERSION").is_ok()
+}
+
+fn is_a_tty(stream: Stream) -> bool {
+ use is_terminal::*;
+ match stream {
+ Stream::Stdout => std::io::stdout().is_terminal(),
+ Stream::Stderr => std::io::stderr().is_terminal(),
+ }
+}
+
+/// Returns true if `stream` is a TTY, and the current terminal
+/// [supports_hyperlinks].
+pub fn on(stream: Stream) -> bool {
+ (std::env::var("FORCE_HYPERLINK").is_ok() || is_a_tty(stream)) && supports_hyperlinks()
+}