summaryrefslogtreecommitdiffstats
path: root/vendor/synstructure/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /vendor/synstructure/Cargo.toml
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/synstructure/Cargo.toml')
-rw-r--r--vendor/synstructure/Cargo.toml36
1 files changed, 30 insertions, 6 deletions
diff --git a/vendor/synstructure/Cargo.toml b/vendor/synstructure/Cargo.toml
index 03398567e..c0587cf4b 100644
--- a/vendor/synstructure/Cargo.toml
+++ b/vendor/synstructure/Cargo.toml
@@ -12,15 +12,27 @@
[package]
edition = "2018"
name = "synstructure"
-version = "0.12.6"
+version = "0.13.0"
authors = ["Nika Layzell <nika@thelayzells.com>"]
-include = ["src/**/*", "Cargo.toml", "README.md", "LICENSE"]
+include = [
+ "src/**/*",
+ "Cargo.toml",
+ "README.md",
+ "LICENSE",
+]
description = "Helper methods and macros for custom derives"
documentation = "https://docs.rs/synstructure"
readme = "README.md"
-keywords = ["syn", "macros", "derive", "expand_substructure", "enum"]
+keywords = [
+ "syn",
+ "macros",
+ "derive",
+ "expand_substructure",
+ "enum",
+]
license = "MIT"
repository = "https://github.com/mystor/synstructure"
+
[dependencies.proc-macro2]
version = "1"
default-features = false
@@ -30,15 +42,27 @@ version = "1"
default-features = false
[dependencies.syn]
-version = "1"
-features = ["derive", "parsing", "printing", "clone-impls", "visit", "extra-traits"]
+version = "2"
+features = [
+ "derive",
+ "parsing",
+ "printing",
+ "clone-impls",
+ "visit",
+ "extra-traits",
+]
default-features = false
[dependencies.unicode-xid]
version = "0.2"
+
[dev-dependencies.synstructure_test_traits]
version = "0.1"
[features]
default = ["proc-macro"]
-proc-macro = ["proc-macro2/proc-macro", "syn/proc-macro", "quote/proc-macro"]
+proc-macro = [
+ "proc-macro2/proc-macro",
+ "syn/proc-macro",
+ "quote/proc-macro",
+]