summaryrefslogtreecommitdiffstats
path: root/vendor/tester/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/tester/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tester/Cargo.toml')
-rw-r--r--vendor/tester/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/vendor/tester/Cargo.toml b/vendor/tester/Cargo.toml
new file mode 100644
index 000000000..14e072d31
--- /dev/null
+++ b/vendor/tester/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "tester"
+version = "0.9.0"
+authors = ["The Rust Project Developers"]
+description = "A fork of Rust’s `test` crate that doesn’t require unstable language features."
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/messense/rustc-test"
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.getopts]
+version = "0.2"
+
+[dependencies.num_cpus]
+version = "1.13.0"
+
+[dependencies.term]
+version = "0.7"
+
+[features]
+asm_black_box = []
+capture = []
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+default-features = false