summaryrefslogtreecommitdiffstats
path: root/vendor/thorin-dwp
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /vendor/thorin-dwp
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/thorin-dwp')
-rw-r--r--vendor/thorin-dwp/.cargo-checksum.json2
-rw-r--r--vendor/thorin-dwp/Cargo.toml9
-rw-r--r--vendor/thorin-dwp/README.md2
-rw-r--r--vendor/thorin-dwp/src/package.rs13
4 files changed, 16 insertions, 10 deletions
diff --git a/vendor/thorin-dwp/.cargo-checksum.json b/vendor/thorin-dwp/.cargo-checksum.json
index 0f21c222b..2e32889ff 100644
--- a/vendor/thorin-dwp/.cargo-checksum.json
+++ b/vendor/thorin-dwp/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"a217c74074725c62fc48d1275978c4bd46117b10cca13526c3de0a57f3be0f5f","README.md":"296c8b1a00a5d53f5c3df1b60047763b3d38e1f28ff98bf58ec07a95cabf78f2","src/error.rs":"7eccbcddfc8694392e7c79e5346c95feb1ea7bd8818de4f59316533cb801518a","src/ext.rs":"a385d1fd8f2102c66a8d5986a2899189a1139683cf6267f63978074867e9a18a","src/index.rs":"060c5c5453e9ec9f2641d4b9d1e8b32dfaf9025510b8fa8d531dd3578640b2d1","src/lib.rs":"25bcb38b09c174fd37004684af0989827ce3bb223b6b25874c687b7ad44408e6","src/package.rs":"43cf081749d232baf60a65a65478e68fc708d8bf308a5b29bd24cfa4120a7ebc","src/relocate.rs":"6a9d7e123bb6d0934847209a1192ed2a23a0502d32a1ccfceccf40726f469618","src/strings.rs":"fb85d8650bccd843bcf5145d8b06a1beec1332eb2b4f7aef9a09f88172ba2688"},"package":"98c040e1340b889d4180c64e1d787efa9c32cb1617757e101480b61238b0d927"} \ No newline at end of file
+{"files":{"Cargo.toml":"625d2e2732fb0bf0d5ae16e65bb392da8ba45dda305baec89f04f79372067d31","README.md":"1d297f6f5f18509a829a603abcf05a62445c3d3f5a749c66be4a1cfc9ed8ea7e","src/error.rs":"7eccbcddfc8694392e7c79e5346c95feb1ea7bd8818de4f59316533cb801518a","src/ext.rs":"a385d1fd8f2102c66a8d5986a2899189a1139683cf6267f63978074867e9a18a","src/index.rs":"060c5c5453e9ec9f2641d4b9d1e8b32dfaf9025510b8fa8d531dd3578640b2d1","src/lib.rs":"25bcb38b09c174fd37004684af0989827ce3bb223b6b25874c687b7ad44408e6","src/package.rs":"04c756bf5cb356f86ed1f839510d72e2941411772d277a1acc87a5e536382833","src/relocate.rs":"6a9d7e123bb6d0934847209a1192ed2a23a0502d32a1ccfceccf40726f469618","src/strings.rs":"fb85d8650bccd843bcf5145d8b06a1beec1332eb2b4f7aef9a09f88172ba2688"},"package":"4db52ee8fec06e119b692ef3dd2c4cf621a99204c1b8c47407870ed050305b9b"} \ No newline at end of file
diff --git a/vendor/thorin-dwp/Cargo.toml b/vendor/thorin-dwp/Cargo.toml
index 99ff2bea5..bb28f1ba9 100644
--- a/vendor/thorin-dwp/Cargo.toml
+++ b/vendor/thorin-dwp/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "thorin-dwp"
-version = "0.6.0"
+version = "0.7.0"
authors = ["David Wood <david.wood@huawei.com>"]
description = "Library for building DWARF packages from input DWARF objects and packages"
homepage = "https://docs.rs/thorin-dwp"
@@ -27,14 +27,13 @@ keywords = [
categories = ["development-tools::debugging"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/thorin"
-resolver = "1"
[lib]
name = "thorin"
bench = false
[dependencies.gimli]
-version = "0.26.1"
+version = "0.28.0"
features = [
"read",
"write",
@@ -43,10 +42,10 @@ features = [
default-features = false
[dependencies.hashbrown]
-version = "0.12.0"
+version = "0.14.0"
[dependencies.object]
-version = "0.31.0"
+version = "0.32.0"
features = [
"archive",
"read",
diff --git a/vendor/thorin-dwp/README.md b/vendor/thorin-dwp/README.md
index 7ca3ca685..a29fa0f93 100644
--- a/vendor/thorin-dwp/README.md
+++ b/vendor/thorin-dwp/README.md
@@ -12,7 +12,7 @@ cross-crate Split DWARF packaging in `rustc`.
To use `thorin` in your own project, add it to your `Cargo.toml`:
```toml
-thorin-dwp = "0.6.0"
+thorin-dwp = "0.7.0"
```
See the [`thorin-bin`](../thorin-bin/README.md) crate for an example of using `thorin`'s library
diff --git a/vendor/thorin-dwp/src/package.rs b/vendor/thorin-dwp/src/package.rs
index b71ae1207..719c4cab1 100644
--- a/vendor/thorin-dwp/src/package.rs
+++ b/vendor/thorin-dwp/src/package.rs
@@ -491,10 +491,17 @@ impl<'file> InProgressDwarfPackage<'file> {
update!(debug_rnglists += self.obj.append_to_debug_rnglists(&data));
}
Ok(".debug_str_offsets.dwo" | ".zdebug_str_offsets.dwo") => {
- let debug_str_offsets_section = {
+ let (debug_str_offsets_section, debug_str_offsets_section_len) = {
let data = section.compressed_data()?.decompress()?;
+ let len = data.len() as u64;
let data_ref = sess.alloc_owned_cow(data);
- gimli::DebugStrOffsets::from(gimli::EndianSlice::new(data_ref, self.endian))
+ (
+ gimli::DebugStrOffsets::from(gimli::EndianSlice::new(
+ data_ref,
+ self.endian,
+ )),
+ len,
+ )
};
let debug_str_section =
@@ -509,7 +516,7 @@ impl<'file> InProgressDwarfPackage<'file> {
let data = self.string_table.remap_str_offsets_section(
debug_str_section,
debug_str_offsets_section,
- section.size(),
+ debug_str_offsets_section_len,
self.endian,
encoding,
)?;