summaryrefslogtreecommitdiffstats
path: root/vendor/tokio-native-tls/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:35 +0000
commitd1b2d29528b7794b41e66fc2136e395a02f8529b (patch)
treea4a17504b260206dec3cf55b2dca82929a348ac2 /vendor/tokio-native-tls/Cargo.toml
parentReleasing progress-linux version 1.72.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.tar.xz
rustc-d1b2d29528b7794b41e66fc2136e395a02f8529b.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tokio-native-tls/Cargo.toml')
-rw-r--r--vendor/tokio-native-tls/Cargo.toml95
1 files changed, 95 insertions, 0 deletions
diff --git a/vendor/tokio-native-tls/Cargo.toml b/vendor/tokio-native-tls/Cargo.toml
new file mode 100644
index 000000000..76be3d393
--- /dev/null
+++ b/vendor/tokio-native-tls/Cargo.toml
@@ -0,0 +1,95 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tokio-native-tls"
+version = "0.3.1"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = """
+An implementation of TLS/SSL streams for Tokio using native-tls giving an implementation of TLS
+for nonblocking I/O streams.
+"""
+homepage = "https://tokio.rs"
+documentation = "https://docs.rs/tokio-native-tls"
+readme = "README.md"
+categories = [
+ "asynchronous",
+ "network-programming",
+]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tls"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.native-tls]
+version = "0.2"
+
+[dependencies.tokio]
+version = "1.0"
+
+[dev-dependencies.cfg-if]
+version = "0.1"
+
+[dev-dependencies.env_logger]
+version = "0.6"
+default-features = false
+
+[dev-dependencies.futures]
+version = "0.3.0"
+features = ["async-await"]
+
+[dev-dependencies.lazy_static]
+version = "1.4.0"
+
+[dev-dependencies.tempfile]
+version = "3.1"
+
+[dev-dependencies.tokio]
+version = "1.0"
+features = [
+ "macros",
+ "rt",
+ "rt-multi-thread",
+ "io-util",
+ "net",
+]
+
+[dev-dependencies.tokio-util]
+version = "0.6.0"
+features = ["full"]
+
+[features]
+vendored = ["native-tls/vendored"]
+
+[target."cfg(all(not(target_os = \"macos\"), not(windows), not(target_os = \"ios\")))".dev-dependencies.openssl]
+version = "0.10"
+
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dev-dependencies.security-framework]
+version = "0.2"
+
+[target."cfg(windows)".dev-dependencies.schannel]
+version = "0.1"
+
+[target."cfg(windows)".dev-dependencies.winapi]
+version = "0.3"
+features = [
+ "lmcons",
+ "basetsd",
+ "minwinbase",
+ "minwindef",
+ "ntdef",
+ "sysinfoapi",
+ "timezoneapi",
+ "wincrypt",
+ "winerror",
+]