summaryrefslogtreecommitdiffstats
path: root/vendor/tracing-error/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/tracing-error/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tracing-error/Cargo.toml')
-rw-r--r--vendor/tracing-error/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/vendor/tracing-error/Cargo.toml b/vendor/tracing-error/Cargo.toml
new file mode 100644
index 000000000..c3ceffc6d
--- /dev/null
+++ b/vendor/tracing-error/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tracing-error"
+version = "0.2.0"
+authors = ["Eliza Weisman <eliza@buoyant.io>", "Jane Lusby <jlusby@yaah.dev>", "Tokio Contributors <team@tokio.rs>"]
+description = "Utilities for enriching errors with `tracing`.\n"
+homepage = "https://tokio.rs"
+readme = "README.md"
+keywords = ["tracing", "error-handling", "exception-reporting", "backtrace"]
+categories = ["development-tools::debugging", "rust-patterns"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tracing"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]
+[dependencies.tracing]
+version = "0.1.12"
+features = ["std"]
+default-features = false
+
+[dependencies.tracing-subscriber]
+version = "0.3"
+features = ["registry", "fmt"]
+default-features = false
+
+[features]
+default = ["traced-error"]
+traced-error = []
+[badges.maintenance]
+status = "experimental"