summaryrefslogtreecommitdiffstats
path: root/vendor/ucd-parse/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/ucd-parse/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/ucd-parse/Cargo.toml')
-rw-r--r--vendor/ucd-parse/Cargo.toml32
1 files changed, 21 insertions, 11 deletions
diff --git a/vendor/ucd-parse/Cargo.toml b/vendor/ucd-parse/Cargo.toml
index f7efa0970..5b2520fcc 100644
--- a/vendor/ucd-parse/Cargo.toml
+++ b/vendor/ucd-parse/Cargo.toml
@@ -3,29 +3,39 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "ucd-parse"
-version = "0.1.8"
+version = "0.1.10"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-description = "A library for parsing data files in the Unicode character database.\n"
+description = """
+A library for parsing data files in the Unicode character database.
+"""
homepage = "https://github.com/BurntSushi/ucd-generate"
documentation = "https://docs.rs/ucd-parse"
readme = "README.md"
-keywords = ["unicode", "database", "character", "property"]
-license = "MIT/Apache-2.0"
+keywords = [
+ "unicode",
+ "database",
+ "character",
+ "property",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/BurntSushi/ucd-generate"
-[dependencies.lazy_static]
+
+[dependencies.once_cell]
version = "1"
[dependencies.regex]
version = "1"
-features = ["std", "unicode"]
+features = [
+ "std",
+ "unicode",
+]
default-features = false