summaryrefslogtreecommitdiffstats
path: root/vendor/ui_test/shell.nix
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/ui_test/shell.nix
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/ui_test/shell.nix')
-rw-r--r--vendor/ui_test/shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/vendor/ui_test/shell.nix b/vendor/ui_test/shell.nix
new file mode 100644
index 000000000..8511dcca9
--- /dev/null
+++ b/vendor/ui_test/shell.nix
@@ -0,0 +1,18 @@
+let
+ pkgs = import <nixpkgs> {};
+in
+pkgs.mkShell rec {
+ name = "rustc";
+ buildInputs = with pkgs; [
+ rustup
+ pkg-config
+ alsaLib
+ libGL
+ xorg.libX11
+ xorg.libXi
+ python39
+ ];
+ RUST_SRC_PATH = "${pkgs.rust.packages.stable.rustPlatform.rustLibSrc}";
+ LD_LIBRARY_PATH = "${pkgs.lib.makeLibraryPath buildInputs}";
+}
+