summaryrefslogtreecommitdiffstats
path: root/vendor/unic-langid-macros-impl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /vendor/unic-langid-macros-impl
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unic-langid-macros-impl')
-rw-r--r--vendor/unic-langid-macros-impl/.cargo-checksum.json2
-rw-r--r--vendor/unic-langid-macros-impl/Cargo.toml29
2 files changed, 21 insertions, 10 deletions
diff --git a/vendor/unic-langid-macros-impl/.cargo-checksum.json b/vendor/unic-langid-macros-impl/.cargo-checksum.json
index 04f0d8d51..e4773cea5 100644
--- a/vendor/unic-langid-macros-impl/.cargo-checksum.json
+++ b/vendor/unic-langid-macros-impl/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"022f8b86153c9050d55f9f1e3877542e6840e9a0cfcb67cc523f1f2089c2b1b7","README.md":"5040022258561c990431417a73521d15ace408b70329a97bc61da94914ed1a75","src/lib.rs":"83231cab2e2ceb3aebd4ec6f103a8ff98d1b52b407e7c9d6c66fba911637379d"},"package":"29396ffd97e27574c3e01368b1a64267d3064969e4848e2e130ff668be9daa9f"} \ No newline at end of file
+{"files":{"Cargo.toml":"64b7309cfef73fbefdec8588f92c91adeebee5b8ee5d824e8e3792763c84f8a6","README.md":"5040022258561c990431417a73521d15ace408b70329a97bc61da94914ed1a75","src/lib.rs":"83231cab2e2ceb3aebd4ec6f103a8ff98d1b52b407e7c9d6c66fba911637379d"},"package":"1f5cdec05b907f4e2f6843f4354f4ce6a5bebe1a56df320a49134944477ce4d8"} \ No newline at end of file
diff --git a/vendor/unic-langid-macros-impl/Cargo.toml b/vendor/unic-langid-macros-impl/Cargo.toml
index ca0b1ee1b..a353df588 100644
--- a/vendor/unic-langid-macros-impl/Cargo.toml
+++ b/vendor/unic-langid-macros-impl/Cargo.toml
@@ -3,19 +3,26 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "unic-langid-macros-impl"
-version = "0.9.0"
-authors = ["Manish Goregaokar <manishsmail@gmail.com>", "Zibi Braniecki <gandalf@mozilla.com>"]
-include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+version = "0.9.1"
+authors = [
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Zibi Braniecki <gandalf@mozilla.com>",
+]
+include = [
+ "src/**/*",
+ "benches/*.rs",
+ "Cargo.toml",
+ "README.md",
+]
description = "API for managing Unicode Language Identifiers"
readme = "README.md"
categories = ["internationalization"]
@@ -24,6 +31,7 @@ repository = "https://github.com/zbraniecki/unic-locale"
[lib]
proc_macro = true
+
[dependencies.proc-macro-hack]
version = "0.5"
@@ -32,7 +40,10 @@ version = "1.0"
[dependencies.syn]
version = "1.0"
-features = ["parsing", "proc-macro"]
+features = [
+ "parsing",
+ "proc-macro",
+]
default-features = false
[dependencies.unic-langid-impl]