summaryrefslogtreecommitdiffstats
path: root/vendor/unic-langid-macros
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /vendor/unic-langid-macros
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unic-langid-macros')
-rw-r--r--vendor/unic-langid-macros/.cargo-checksum.json2
-rw-r--r--vendor/unic-langid-macros/Cargo.toml26
2 files changed, 18 insertions, 10 deletions
diff --git a/vendor/unic-langid-macros/.cargo-checksum.json b/vendor/unic-langid-macros/.cargo-checksum.json
index 6d9e4d7e9..643d0d603 100644
--- a/vendor/unic-langid-macros/.cargo-checksum.json
+++ b/vendor/unic-langid-macros/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"37b883b01864161cffe562ddcc7226d60a6a104229da7b5f269a18738782efb7","README.md":"6bab9883bd094c16d22f7aeddb59b391c1567c167ffed2f28aee9e2a82de1a1d","src/lib.rs":"f850878a5d545496073593ef1ca340ef385f78bc6585c5d3b46fe8ffc2087bd5"},"package":"18f980d6d87e8805f2836d64b4138cc95aa7986fa63b1f51f67d5fbff64dd6e5"} \ No newline at end of file
+{"files":{"Cargo.toml":"debce559451d7edd257495d2f7a8c3bd081e1ec15625d42668165cec8f2a4cf7","README.md":"6bab9883bd094c16d22f7aeddb59b391c1567c167ffed2f28aee9e2a82de1a1d","src/lib.rs":"f850878a5d545496073593ef1ca340ef385f78bc6585c5d3b46fe8ffc2087bd5"},"package":"055e618bf694161ffff0466d95cef3e1a5edc59f6ba1888e97801f2b4ebdc4fe"} \ No newline at end of file
diff --git a/vendor/unic-langid-macros/Cargo.toml b/vendor/unic-langid-macros/Cargo.toml
index 52a46e809..55fad3cfc 100644
--- a/vendor/unic-langid-macros/Cargo.toml
+++ b/vendor/unic-langid-macros/Cargo.toml
@@ -3,29 +3,37 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "unic-langid-macros"
-version = "0.9.0"
-authors = ["Manish Goregaokar <manishsmail@gmail.com>", "Zibi Braniecki <gandalf@mozilla.com>"]
-include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+version = "0.9.1"
+authors = [
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Zibi Braniecki <gandalf@mozilla.com>",
+]
+include = [
+ "src/**/*",
+ "benches/*.rs",
+ "Cargo.toml",
+ "README.md",
+]
description = "API for managing Unicode Language Identifiers"
readme = "README.md"
categories = ["internationalization"]
license = "MIT/Apache-2.0"
repository = "https://github.com/zbraniecki/unic-locale"
+
[dependencies.proc-macro-hack]
version = "0.5"
[dependencies.tinystr]
-version = "0.3.2"
+version = "0.7.0"
[dependencies.unic-langid-impl]
version = "0.9"