summaryrefslogtreecommitdiffstats
path: root/vendor/unic-langid-macros
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/unic-langid-macros
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unic-langid-macros')
-rw-r--r--vendor/unic-langid-macros/.cargo-checksum.json1
-rw-r--r--vendor/unic-langid-macros/Cargo.toml34
-rw-r--r--vendor/unic-langid-macros/README.md1
-rw-r--r--vendor/unic-langid-macros/src/lib.rs17
4 files changed, 53 insertions, 0 deletions
diff --git a/vendor/unic-langid-macros/.cargo-checksum.json b/vendor/unic-langid-macros/.cargo-checksum.json
new file mode 100644
index 000000000..6d9e4d7e9
--- /dev/null
+++ b/vendor/unic-langid-macros/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"37b883b01864161cffe562ddcc7226d60a6a104229da7b5f269a18738782efb7","README.md":"6bab9883bd094c16d22f7aeddb59b391c1567c167ffed2f28aee9e2a82de1a1d","src/lib.rs":"f850878a5d545496073593ef1ca340ef385f78bc6585c5d3b46fe8ffc2087bd5"},"package":"18f980d6d87e8805f2836d64b4138cc95aa7986fa63b1f51f67d5fbff64dd6e5"} \ No newline at end of file
diff --git a/vendor/unic-langid-macros/Cargo.toml b/vendor/unic-langid-macros/Cargo.toml
new file mode 100644
index 000000000..52a46e809
--- /dev/null
+++ b/vendor/unic-langid-macros/Cargo.toml
@@ -0,0 +1,34 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "unic-langid-macros"
+version = "0.9.0"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>", "Zibi Braniecki <gandalf@mozilla.com>"]
+include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+description = "API for managing Unicode Language Identifiers"
+readme = "README.md"
+categories = ["internationalization"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/zbraniecki/unic-locale"
+[dependencies.proc-macro-hack]
+version = "0.5"
+
+[dependencies.tinystr]
+version = "0.3.2"
+
+[dependencies.unic-langid-impl]
+version = "0.9"
+
+[dependencies.unic-langid-macros-impl]
+version = "0.9"
diff --git a/vendor/unic-langid-macros/README.md b/vendor/unic-langid-macros/README.md
new file mode 100644
index 000000000..4497b805d
--- /dev/null
+++ b/vendor/unic-langid-macros/README.md
@@ -0,0 +1 @@
+This is an internal macro declaration crate for `unic-langid`. Please use `unic-langid` instead.
diff --git a/vendor/unic-langid-macros/src/lib.rs b/vendor/unic-langid-macros/src/lib.rs
new file mode 100644
index 000000000..9e075e15c
--- /dev/null
+++ b/vendor/unic-langid-macros/src/lib.rs
@@ -0,0 +1,17 @@
+use proc_macro_hack::proc_macro_hack;
+pub use unic_langid_impl::{subtags, LanguageIdentifier};
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::langid;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::lang;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::script;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::region;
+
+#[proc_macro_hack]
+pub use unic_langid_macros_impl::variant_fn as variant;