summaryrefslogtreecommitdiffstats
path: root/vendor/unicode-bidi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/unicode-bidi/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unicode-bidi/Cargo.toml')
-rw-r--r--vendor/unicode-bidi/Cargo.toml78
1 files changed, 78 insertions, 0 deletions
diff --git a/vendor/unicode-bidi/Cargo.toml b/vendor/unicode-bidi/Cargo.toml
new file mode 100644
index 000000000..9a8ca4a32
--- /dev/null
+++ b/vendor/unicode-bidi/Cargo.toml
@@ -0,0 +1,78 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "unicode-bidi"
+version = "0.3.8"
+authors = ["The Servo Project Developers"]
+exclude = [
+ "benches/**",
+ "data/**",
+ "examples/**",
+ "tests/**",
+ "tools/**",
+]
+description = "Implementation of the Unicode Bidirectional Algorithm"
+documentation = "https://docs.rs/unicode-bidi/"
+readme = "README.md"
+keywords = [
+ "rtl",
+ "unicode",
+ "text",
+ "layout",
+ "bidi",
+]
+categories = [
+ "no-std",
+ "encoding",
+ "text-processing",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/servo/unicode-bidi"
+
+[lib]
+name = "unicode_bidi"
+
+[dependencies.flame]
+version = "0.2"
+optional = true
+
+[dependencies.flamer]
+version = "0.4"
+optional = true
+
+[dependencies.serde]
+version = ">=0.8, <2.0"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dev-dependencies.serde_test]
+version = ">=0.8, <2.0"
+
+[features]
+bench_it = []
+default = [
+ "std",
+ "hardcoded-data",
+]
+flame_it = [
+ "flame",
+ "flamer",
+]
+hardcoded-data = []
+std = []
+unstable = []
+with_serde = ["serde"]
+
+[badges.appveyor]
+repository = "servo/unicode-bidi"