summaryrefslogtreecommitdiffstats
path: root/vendor/unwinding/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
commit9918693037dce8aa4bb6f08741b6812923486c18 (patch)
tree21d2b40bec7e6a7ea664acee056eb3d08e15a1cf /vendor/unwinding/Cargo.toml
parentReleasing progress-linux version 1.75.0+dfsg1-5~progress7.99u1. (diff)
downloadrustc-9918693037dce8aa4bb6f08741b6812923486c18.tar.xz
rustc-9918693037dce8aa4bb6f08741b6812923486c18.zip
Merging upstream version 1.76.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unwinding/Cargo.toml')
-rw-r--r--vendor/unwinding/Cargo.toml92
1 files changed, 92 insertions, 0 deletions
diff --git a/vendor/unwinding/Cargo.toml b/vendor/unwinding/Cargo.toml
new file mode 100644
index 000000000..851d1eee0
--- /dev/null
+++ b/vendor/unwinding/Cargo.toml
@@ -0,0 +1,92 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "unwinding"
+version = "0.2.1"
+authors = ["Gary Guo <gary@garyguo.net>"]
+description = "Unwinding library in Rust and for Rust"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/nbdd0121/unwinding/"
+
+[package.metadata.docs.rs]
+features = ["panic-handler"]
+
+[profile.release]
+debug = 2
+
+[dependencies.compiler_builtins]
+version = "0.1.2"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.gimli]
+version = "0.28"
+features = ["read-core"]
+default-features = false
+
+[dependencies.libc]
+version = "0.2"
+optional = true
+
+[dependencies.spin]
+version = "0.9.8"
+features = [
+ "mutex",
+ "spin_mutex",
+]
+optional = true
+default-features = false
+
+[features]
+alloc = []
+default = [
+ "unwinder",
+ "dwarf-expr",
+ "hide-trace",
+ "fde-phdr-dl",
+ "fde-registry",
+]
+dwarf-expr = []
+fde-custom = []
+fde-gnu-eh-frame-hdr = []
+fde-phdr = ["libc"]
+fde-phdr-aux = ["fde-phdr"]
+fde-phdr-dl = ["fde-phdr"]
+fde-registry = ["alloc"]
+fde-static = []
+hide-trace = []
+panic = [
+ "panicking",
+ "alloc",
+]
+panic-handler = [
+ "print",
+ "panic",
+]
+panic-handler-dummy = []
+panicking = []
+personality = []
+personality-dummy = []
+print = ["libc"]
+rustc-dep-of-std = [
+ "core",
+ "gimli/rustc-dep-of-std",
+ "compiler_builtins",
+]
+system-alloc = []
+unwinder = []