summaryrefslogtreecommitdiffstats
path: root/vendor/varisat-dimacs/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/varisat-dimacs/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/varisat-dimacs/Cargo.toml')
-rw-r--r--vendor/varisat-dimacs/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/vendor/varisat-dimacs/Cargo.toml b/vendor/varisat-dimacs/Cargo.toml
new file mode 100644
index 000000000..c44c54d63
--- /dev/null
+++ b/vendor/varisat-dimacs/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "varisat-dimacs"
+version = "0.2.2"
+authors = ["Jannis Harder <me@jix.one>"]
+description = "DIMCAS CNF parser and writer for the Varisat SAT solver"
+homepage = "https://jix.one/project/varisat/"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jix/varisat"
+[dependencies.anyhow]
+version = "1.0.32"
+
+[dependencies.itoa]
+version = "0.4.4"
+
+[dependencies.thiserror]
+version = "1.0.20"
+
+[dependencies.varisat-formula]
+version = "=0.2.2"
+[dev-dependencies.env_logger]
+version = "0.7.1"
+
+[dev-dependencies.proptest]
+version = "0.10.1"
+
+[dev-dependencies.rand]
+version = "0.7.3"
+
+[dev-dependencies.tempfile]
+version = "3.0.8"
+
+[dev-dependencies.varisat-formula]
+version = "=0.2.2"
+features = ["proptest-strategies", "internal-testing"]