summaryrefslogtreecommitdiffstats
path: root/vendor/varisat-internal-macros
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/varisat-internal-macros
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/varisat-internal-macros')
-rw-r--r--vendor/varisat-internal-macros/.cargo-checksum.json1
-rw-r--r--vendor/varisat-internal-macros/Cargo.toml39
-rw-r--r--vendor/varisat-internal-macros/LICENSE-APACHE201
-rw-r--r--vendor/varisat-internal-macros/LICENSE-MIT25
-rw-r--r--vendor/varisat-internal-macros/README.md27
-rw-r--r--vendor/varisat-internal-macros/src/lib.rs216
6 files changed, 509 insertions, 0 deletions
diff --git a/vendor/varisat-internal-macros/.cargo-checksum.json b/vendor/varisat-internal-macros/.cargo-checksum.json
new file mode 100644
index 000000000..ad98a3515
--- /dev/null
+++ b/vendor/varisat-internal-macros/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"048c2dffa7a2ebbc4167a6b16d1b28ae7216dbeaa68dd5b44755be3af529900b","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"2259cbb177661977dd5510c05a8670da3cb28aa7f4ff74c193798db496fe92d8","README.md":"c65ea3ac2a3d94027b866b5966a409838162c917bdf091d3549acfd97415c531","src/lib.rs":"e04f3d25cc7a3f490020618ff2f18171e66cfe76bf30dd5dd7e59d82faf72dfc"},"package":"602ece773543d066aa7848455486c6c0422a3f214da7a2b899100f3c4f12408d"} \ No newline at end of file
diff --git a/vendor/varisat-internal-macros/Cargo.toml b/vendor/varisat-internal-macros/Cargo.toml
new file mode 100644
index 000000000..3ecc5c2d7
--- /dev/null
+++ b/vendor/varisat-internal-macros/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "varisat-internal-macros"
+version = "0.2.2"
+authors = ["Jannis Harder <me@jix.one>"]
+description = "Internal macros for the Varisat SAT solver"
+homepage = "https://jix.one/project/varisat/"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jix/varisat"
+
+[lib]
+proc-macro = true
+[dependencies.proc-macro2]
+version = "1.0.20"
+
+[dependencies.quote]
+version = "1.0.7"
+
+[dependencies.regex]
+version = "1.1.6"
+
+[dependencies.syn]
+version = "1.0.40"
+
+[dependencies.synstructure]
+version = "0.12.4"
diff --git a/vendor/varisat-internal-macros/LICENSE-APACHE b/vendor/varisat-internal-macros/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/varisat-internal-macros/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/varisat-internal-macros/LICENSE-MIT b/vendor/varisat-internal-macros/LICENSE-MIT
new file mode 100644
index 000000000..4fd1cb2ff
--- /dev/null
+++ b/vendor/varisat-internal-macros/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2017-2019 Jannis Harder
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/varisat-internal-macros/README.md b/vendor/varisat-internal-macros/README.md
new file mode 100644
index 000000000..2b4e76a63
--- /dev/null
+++ b/vendor/varisat-internal-macros/README.md
@@ -0,0 +1,27 @@
+# Varisat
+
+This crate contains macros used internally by the [`varisat`
+crate][crate-varisat].
+
+__This is an internal dependency of the Varisat SAT solver, and should not be
+used directly.__
+
+## License
+
+The Varisat source code is licensed under either of
+
+ * Apache License, Version 2.0
+ ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license
+ ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in Varisat by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.
+
+[crate-varisat]: https://crates.io/crates/varisat
diff --git a/vendor/varisat-internal-macros/src/lib.rs b/vendor/varisat-internal-macros/src/lib.rs
new file mode 100644
index 000000000..f6bfc8f25
--- /dev/null
+++ b/vendor/varisat-internal-macros/src/lib.rs
@@ -0,0 +1,216 @@
+//! Internal macros for the Varisat SAT solver.
+#![recursion_limit = "128"]
+use std::fmt::Write;
+
+use proc_macro2::TokenStream;
+use quote::quote;
+use syn::{
+ parse_quote, punctuated::Punctuated, Attribute, Fields, Ident, Lit, LitStr, Meta,
+ MetaNameValue, Token,
+};
+use synstructure::decl_derive;
+
+/// Get the doc comment as LitStr from the attributes
+fn doc_from_attrs(attrs: &[Attribute]) -> Vec<LitStr> {
+ let mut lines = vec![];
+
+ for attr in attrs.iter() {
+ if let Ok(Meta::NameValue(MetaNameValue {
+ path,
+ lit: Lit::Str(doc_str),
+ ..
+ })) = attr.parse_meta()
+ {
+ if let Some(ident) = path.get_ident() {
+ if ident == "doc" {
+ lines.push(doc_str);
+ }
+ }
+ }
+ }
+
+ lines
+}
+
+/// Find a field inside the doc comment
+fn get_doc_field(name: &str, attrs: &[Attribute]) -> Option<LitStr> {
+ let re = regex::Regex::new(&format!(r"\[{}: (.+?)\]( |$)", regex::escape(name))).unwrap();
+
+ for doc_str in doc_from_attrs(attrs) {
+ if let Some(expr_str) = re.captures(&doc_str.value()) {
+ let expr_str = expr_str.get(1).unwrap().as_str();
+ let expr_str = LitStr::new(expr_str, doc_str.span());
+ return Some(expr_str);
+ }
+ }
+
+ None
+}
+
+/// Derives a default instance from the documentation.
+fn derive_doc_default(s: synstructure::Structure) -> TokenStream {
+ let variant = match s.variants() {
+ [variant] => variant,
+ _ => panic!("DocDefault requires a struct"),
+ };
+
+ let body = variant.construct(|field, _| {
+ get_doc_field("default", &field.attrs)
+ .map(|expr_str| {
+ expr_str
+ .parse::<TokenStream>()
+ .expect("error parsing default expression")
+ })
+ .unwrap_or_else(|| parse_quote!(Default::default()))
+ });
+
+ s.gen_impl(quote! {
+ gen impl Default for @Self {
+ fn default() -> Self {
+ #body
+ }
+ }
+ })
+}
+
+decl_derive!([DocDefault] => derive_doc_default);
+
+/// Derives an update struct and method for a config struct.
+fn derive_config_update(s: synstructure::Structure) -> TokenStream {
+ let variant = match s.variants() {
+ [variant] => variant,
+ _ => panic!("ConfigUpdate requires a struct"),
+ };
+
+ let fields = match variant.ast().fields {
+ Fields::Named(fields_named) => &fields_named.named,
+ _ => panic!("ConfigUpdate requires named fields"),
+ };
+
+ assert!(
+ s.referenced_ty_params().is_empty(),
+ "ConfigUpdate doesn't support type parameters"
+ );
+
+ let ident = &s.ast().ident;
+ let update_struct_ident = Ident::new(&format!("{}Update", ident), ident.span());
+
+ let vis = &s.ast().vis;
+
+ let update_struct_body = fields
+ .iter()
+ .map(|field| {
+ let ty = &field.ty;
+ let mut field = field.clone();
+ field.ty = parse_quote!(Option<#ty>);
+ field
+ })
+ .collect::<Punctuated<_, Token![,]>>();
+
+ let check_ranges = fields
+ .iter()
+ .map(|field| {
+ if let Some(range) = get_doc_field("range", &field.attrs) {
+ // TODO use toml instead of fmt::Debug for errors?
+ let ident = &field.ident;
+ let error_msg = format!(
+ "{} must be in range {} but was set to {{:?}}",
+ quote!(#ident),
+ range.value()
+ );
+ let range = range
+ .parse::<TokenStream>()
+ .expect("error parsing range expression");
+ quote! {
+ if let Some(value) = &self.#ident {
+ anyhow::ensure!((#range).contains(value), #error_msg, value);
+ }
+ }
+ } else {
+ quote!()
+ }
+ })
+ .collect::<TokenStream>();
+
+ let apply_updates = fields
+ .iter()
+ .map(|field| {
+ let ident = &field.ident;
+ quote! {
+ if let Some(value) = &self.#ident {
+ config.#ident = value.clone();
+ }
+ }
+ })
+ .collect::<TokenStream>();
+
+ let merge_updates = fields
+ .iter()
+ .map(|field| {
+ let ident = &field.ident;
+ quote! {
+ if let Some(value) = config_update.#ident {
+ self.#ident = Some(value);
+ }
+ }
+ })
+ .collect::<TokenStream>();
+
+ let mut help_str = String::new();
+
+ for field in fields.iter() {
+ let ident = &field.ident;
+ writeln!(&mut help_str, "{}:", quote!(#ident)).unwrap();
+ for line in doc_from_attrs(&field.attrs).iter() {
+ if line.value().is_empty() {
+ writeln!(&mut help_str).unwrap();
+ } else {
+ writeln!(&mut help_str, " {}", line.value()).unwrap();
+ }
+ }
+ writeln!(&mut help_str).unwrap();
+ }
+
+ let doc = format!("Updates configuration values of [`{}`].", ident);
+
+ quote! {
+ #[doc = #doc]
+ #[derive(Default, serde::Serialize, serde::Deserialize)]
+ #[serde(deny_unknown_fields)]
+ #vis struct #update_struct_ident {
+ #update_struct_body
+ }
+
+ impl #ident {
+ /// Return a string describing all supported configuration options.
+ pub fn help() -> &'static str {
+ #help_str
+ }
+ }
+
+ impl #update_struct_ident {
+ /// Create an empty config update.
+ pub fn new() -> #update_struct_ident {
+ #update_struct_ident::default()
+ }
+
+ /// Apply the configuration update.
+ ///
+ /// If an error occurs, the configuration is not changed.
+ pub fn apply(&self, config: &mut #ident) -> Result<(), anyhow::Error> {
+ #check_ranges
+ #apply_updates
+ Ok(())
+ }
+
+ /// Merge two configuration updates.
+ ///
+ /// Add the given update, overwriting values of the receiving update.
+ pub fn merge(&mut self, config_update: #update_struct_ident) {
+ #merge_updates
+ }
+ }
+ }
+}
+
+decl_derive!([ConfigUpdate] => derive_config_update);