summaryrefslogtreecommitdiffstats
path: root/vendor/vcpkg/tests/vcpkgrs_target.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/vcpkg/tests/vcpkgrs_target.sh
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/vcpkg/tests/vcpkgrs_target.sh')
-rw-r--r--vendor/vcpkg/tests/vcpkgrs_target.sh22
1 files changed, 22 insertions, 0 deletions
diff --git a/vendor/vcpkg/tests/vcpkgrs_target.sh b/vendor/vcpkg/tests/vcpkgrs_target.sh
new file mode 100644
index 000000000..ba46fbf35
--- /dev/null
+++ b/vendor/vcpkg/tests/vcpkgrs_target.sh
@@ -0,0 +1,22 @@
+#!/bin/bash
+set -ex
+
+SCRIPTDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
+cd $SCRIPTDIR
+
+export VCPKG_ROOT=$SCRIPTDIR/../vcp
+export VCPKGRS_TRIPLET=test-triplet
+export VCPKG_DEFAULT_TRIPLET=test-triplet
+
+cp $VCPKG_ROOT/triplets/x64-linux.cmake $VCPKG_ROOT/triplets/test-triplet.cmake
+for port in harfbuzz ; do
+ # check that the port fails before it is installed
+ $VCPKG_ROOT/vcpkg remove --no-binarycaching $port || true
+ cargo clean --manifest-path $port/Cargo.toml
+ cargo run --manifest-path $port/Cargo.toml && exit 2
+ echo THIS FAILURE IS EXPECTED
+ echo This is to ensure that we are not spuriously succeeding because the libraries already exist somewhere on the build machine.
+ # disable binary caching because it breaks this build as of vcpkg 53e6588 (since vcpkg 52a9d9a)
+ $VCPKG_ROOT/vcpkg install --no-binarycaching $port
+ cargo run --manifest-path $port/Cargo.toml
+done