summaryrefslogtreecommitdiffstats
path: root/vendor/vec_mut_scan/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/vec_mut_scan/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/vec_mut_scan/Cargo.toml')
-rw-r--r--vendor/vec_mut_scan/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/vendor/vec_mut_scan/Cargo.toml b/vendor/vec_mut_scan/Cargo.toml
new file mode 100644
index 000000000..f37016bfc
--- /dev/null
+++ b/vendor/vec_mut_scan/Cargo.toml
@@ -0,0 +1,25 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "vec_mut_scan"
+version = "0.3.0"
+authors = ["Jannis Harder <me@jix.one>"]
+description = "Forward scan over a vector with mutation and item removal"
+readme = "README.md"
+keywords = ["vec", "retain", "drain", "drain_filter"]
+categories = ["algorithms", "data-structures"]
+license = "0BSD"
+repository = "https://github.com/jix/vec_mut_scan"
+
+[dependencies]