summaryrefslogtreecommitdiffstats
path: root/vendor/wasm-bindgen-macro-support/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:19 +0000
commita0b8f38ab54ac451646aa00cd5e91b6c76f22a84 (patch)
treefc451898ccaf445814e26b46664d78702178101d /vendor/wasm-bindgen-macro-support/Cargo.toml
parentAdding debian version 1.71.1+dfsg1-2. (diff)
downloadrustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.tar.xz
rustc-a0b8f38ab54ac451646aa00cd5e91b6c76f22a84.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/wasm-bindgen-macro-support/Cargo.toml')
-rw-r--r--vendor/wasm-bindgen-macro-support/Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/vendor/wasm-bindgen-macro-support/Cargo.toml b/vendor/wasm-bindgen-macro-support/Cargo.toml
index 1b9116155..36bb02447 100644
--- a/vendor/wasm-bindgen-macro-support/Cargo.toml
+++ b/vendor/wasm-bindgen-macro-support/Cargo.toml
@@ -11,8 +11,9 @@
[package]
edition = "2018"
+rust-version = "1.56"
name = "wasm-bindgen-macro-support"
-version = "0.2.84"
+version = "0.2.87"
authors = ["The wasm-bindgen Developers"]
description = """
The part of the implementation of the `#[wasm_bindgen]` attribute that is not in the shared backend crate
@@ -21,6 +22,7 @@ homepage = "https://rustwasm.github.io/wasm-bindgen/"
documentation = "https://docs.rs/wasm-bindgen"
license = "MIT/Apache-2.0"
repository = "https://github.com/rustwasm/wasm-bindgen/tree/master/crates/macro-support"
+resolver = "2"
[dependencies.proc-macro2]
version = "1.0"
@@ -29,17 +31,17 @@ version = "1.0"
version = "1.0"
[dependencies.syn]
-version = "1.0.84"
+version = "2.0"
features = [
"visit",
"full",
]
[dependencies.wasm-bindgen-backend]
-version = "=0.2.84"
+version = "=0.2.87"
[dependencies.wasm-bindgen-shared]
-version = "=0.2.84"
+version = "=0.2.87"
[features]
extra-traits = ["syn/extra-traits"]