summaryrefslogtreecommitdiffstats
path: root/vendor/wasm-bindgen-shared/src
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/wasm-bindgen-shared/src
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/wasm-bindgen-shared/src')
-rw-r--r--vendor/wasm-bindgen-shared/src/lib.rs8
-rw-r--r--vendor/wasm-bindgen-shared/src/schema_hash_approval.rs2
2 files changed, 8 insertions, 2 deletions
diff --git a/vendor/wasm-bindgen-shared/src/lib.rs b/vendor/wasm-bindgen-shared/src/lib.rs
index f69d8f4a8..408613be9 100644
--- a/vendor/wasm-bindgen-shared/src/lib.rs
+++ b/vendor/wasm-bindgen-shared/src/lib.rs
@@ -6,7 +6,7 @@ mod schema_hash_approval;
// This gets changed whenever our schema changes.
// At this time versions of wasm-bindgen and wasm-bindgen-cli are required to have the exact same
// SCHEMA_VERSION in order to work together.
-pub const SCHEMA_VERSION: &str = "0.2.83";
+pub const SCHEMA_VERSION: &str = "0.2.84";
#[macro_export]
macro_rules! shared_api {
@@ -22,6 +22,7 @@ macro_rules! shared_api {
inline_js: Vec<&'a str>,
unique_crate_identifier: &'a str,
package_json: Option<&'a str>,
+ linked_modules: Vec<LinkedModule<'a>>,
}
struct Import<'a> {
@@ -30,6 +31,11 @@ macro_rules! shared_api {
kind: ImportKind<'a>,
}
+ struct LinkedModule<'a> {
+ module: ImportModule<'a>,
+ link_function_name: &'a str,
+ }
+
enum ImportModule<'a> {
Named(&'a str),
RawNamed(&'a str),
diff --git a/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs b/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs
index 4692a28c8..0d4d0bb38 100644
--- a/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs
+++ b/vendor/wasm-bindgen-shared/src/schema_hash_approval.rs
@@ -8,7 +8,7 @@
// If the schema in this library has changed then:
// 1. Bump the version in `crates/shared/Cargo.toml`
// 2. Change the `SCHEMA_VERSION` in this library to this new Cargo.toml version
-const APPROVED_SCHEMA_FILE_HASH: &'static str = "17656911631008664055";
+const APPROVED_SCHEMA_FILE_HASH: &'static str = "584864585234329974";
#[test]
fn schema_version() {