summaryrefslogtreecommitdiffstats
path: root/vendor/wasm-bindgen/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/wasm-bindgen/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/wasm-bindgen/Cargo.toml')
-rw-r--r--vendor/wasm-bindgen/Cargo.toml79
1 files changed, 79 insertions, 0 deletions
diff --git a/vendor/wasm-bindgen/Cargo.toml b/vendor/wasm-bindgen/Cargo.toml
new file mode 100644
index 000000000..87709d49f
--- /dev/null
+++ b/vendor/wasm-bindgen/Cargo.toml
@@ -0,0 +1,79 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "wasm-bindgen"
+version = "0.2.83"
+authors = ["The wasm-bindgen Developers"]
+description = """
+Easy support for interacting between JS and Rust.
+"""
+homepage = "https://rustwasm.github.io/"
+documentation = "https://docs.rs/wasm-bindgen"
+readme = "README.md"
+categories = ["wasm"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rustwasm/wasm-bindgen"
+
+[package.metadata.docs.rs]
+features = ["serde-serialize"]
+
+[lib]
+test = false
+
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[dependencies.wasm-bindgen-macro]
+version = "=0.2.83"
+
+[features]
+default = [
+ "spans",
+ "std",
+]
+enable-interning = ["std"]
+serde-serialize = [
+ "serde",
+ "serde_json",
+ "std",
+]
+spans = ["wasm-bindgen-macro/spans"]
+std = []
+strict-macro = ["wasm-bindgen-macro/strict-macro"]
+xxx_debug_only_print_generated_code = ["wasm-bindgen-macro/xxx_debug_only_print_generated_code"]
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.js-sys]
+version = "0.3.60"
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.serde_derive]
+version = "1.0"
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-futures]
+version = "=0.4.33"
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
+version = "=0.3.33"
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test-crate-a]
+version = "0.1"
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test-crate-b]
+version = "0.1"