summaryrefslogtreecommitdiffstats
path: root/vendor/wasm-bindgen/releases
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/wasm-bindgen/releases
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/wasm-bindgen/releases')
-rwxr-xr-xvendor/wasm-bindgen/releases/friends.sh19
-rw-r--r--vendor/wasm-bindgen/releases/release-announcement-template.md39
2 files changed, 58 insertions, 0 deletions
diff --git a/vendor/wasm-bindgen/releases/friends.sh b/vendor/wasm-bindgen/releases/friends.sh
new file mode 100755
index 000000000..4486b4229
--- /dev/null
+++ b/vendor/wasm-bindgen/releases/friends.sh
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+set -eu
+set -o pipefail
+
+cd $(dirname $0)
+
+if [[ -z "${1+x}" ]]; then
+ read -p "List friends since which commit/tag? " since
+ echo
+else
+ since=$1
+fi
+
+git shortlog -s -n "$since.." \
+ | cut -f 2- \
+ | sort -u \
+ | grep -v bors\-servo \
+ | xargs -d '\n' -I{} echo "- {}"
diff --git a/vendor/wasm-bindgen/releases/release-announcement-template.md b/vendor/wasm-bindgen/releases/release-announcement-template.md
new file mode 100644
index 000000000..a1feaf4b6
--- /dev/null
+++ b/vendor/wasm-bindgen/releases/release-announcement-template.md
@@ -0,0 +1,39 @@
+# Announcing `wasm-bindgen` $TODO_VERSION
+
+`wasm-bindgen` facilitates high-level interactions between wasm modules and
+JavaScript.
+
+* [GitHub][]
+* [crates.io][]
+* [The `wasm-bindgen` Guide][guide]
+
+Upgrade to this release by updating your `Cargo.toml`:
+
+```toml
+wasm-bindgen = "$TODO_VERSION"
+```
+
+## Changelog
+
+<insert relevant section of CHANGELOG.md here>
+
+## Friends
+
+Thanks to everyone who contributed to this release!
+
+<insert the output of friends.sh here>
+
+## Contributing
+
+Want to join us? Check out our [The "Contributing" section of the
+guide][contributing] and take a look at some of these issues:
+
+* [Issues labeled "good first issue"][good-first-issue]
+* [Issues labeled "help wanted"][help-wanted]
+
+[GitHub]: https://github.com/rustwasm/wasm-bindgen
+[crates.io]: https://crates.io/crates/wasm-bindgen
+[guide]: https://rustwasm.github.io/wasm-bindgen
+[contributing]: https://rustwasm.github.io/wasm-bindgen/contributing.md
+[good-first-issue]: https://github.com/rustwasm/wasm-bindgen/labels/good%20first%20issue
+[help-wanted]: https://github.com/rustwasm/wasm-bindgen/labels/help%20wanted