summaryrefslogtreecommitdiffstats
path: root/vendor/web-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/web-sys/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/web-sys/Cargo.toml')
-rw-r--r--vendor/web-sys/Cargo.toml71
1 files changed, 60 insertions, 11 deletions
diff --git a/vendor/web-sys/Cargo.toml b/vendor/web-sys/Cargo.toml
index 6fcf87bc0..d2d8c063a 100644
--- a/vendor/web-sys/Cargo.toml
+++ b/vendor/web-sys/Cargo.toml
@@ -11,8 +11,9 @@
[package]
edition = "2018"
+rust-version = "1.56"
name = "web-sys"
-version = "0.3.61"
+version = "0.3.64"
authors = ["The wasm-bindgen Developers"]
description = """
Bindings for all Web APIs, a procedurally generated crate from WebIDL
@@ -22,6 +23,7 @@ documentation = "https://rustwasm.github.io/wasm-bindgen/api/web_sys/"
readme = "./README.md"
license = "MIT/Apache-2.0"
repository = "https://github.com/rustwasm/wasm-bindgen/tree/master/crates/web-sys"
+resolver = "2"
[package.metadata.docs.rs]
all-features = true
@@ -32,10 +34,10 @@ test = false
doctest = false
[dependencies.js-sys]
-version = "0.3.61"
+version = "0.3.64"
[dependencies.wasm-bindgen]
-version = "0.2.84"
+version = "0.2.87"
[features]
AbortController = []
@@ -199,6 +201,10 @@ CanvasCaptureMediaStream = [
"EventTarget",
"MediaStream",
]
+CanvasCaptureMediaStreamTrack = [
+ "EventTarget",
+ "MediaStreamTrack",
+]
CanvasGradient = []
CanvasPattern = []
CanvasRenderingContext2d = []
@@ -219,8 +225,6 @@ ChannelMergerNode = [
"EventTarget",
]
ChannelMergerOptions = []
-ChannelPixelLayout = []
-ChannelPixelLayoutDataType = []
ChannelSplitterNode = [
"AudioNode",
"EventTarget",
@@ -504,13 +508,24 @@ FilePropertyBag = []
FileReader = ["EventTarget"]
FileReaderSync = []
FileSystem = []
+FileSystemCreateWritableOptions = []
FileSystemDirectoryEntry = ["FileSystemEntry"]
+FileSystemDirectoryHandle = ["FileSystemHandle"]
FileSystemDirectoryReader = []
FileSystemEntriesCallback = []
FileSystemEntry = []
FileSystemEntryCallback = []
FileSystemFileEntry = ["FileSystemEntry"]
+FileSystemFileHandle = ["FileSystemHandle"]
FileSystemFlags = []
+FileSystemGetDirectoryOptions = []
+FileSystemGetFileOptions = []
+FileSystemHandle = []
+FileSystemHandleKind = []
+FileSystemReadWriteOptions = []
+FileSystemRemoveOptions = []
+FileSystemSyncAccessHandle = []
+FileSystemWritableFileStream = ["WritableStream"]
FillMode = []
FlashClassification = []
FlexLineGrowthState = []
@@ -520,6 +535,7 @@ FocusEvent = [
"UiEvent",
]
FocusEventInit = []
+FontData = []
FontFace = []
FontFaceDescriptors = []
FontFaceLoadStatus = []
@@ -558,6 +574,7 @@ GamepadMappingType = []
GamepadPose = []
GamepadServiceTest = []
Geolocation = []
+GetAnimationsOptions = []
GetNotificationOptions = []
GetRootNodeOptions = []
GetUserMediaRequest = []
@@ -1194,7 +1211,6 @@ IirFilterNode = [
]
IirFilterOptions = []
ImageBitmap = []
-ImageBitmapFormat = []
ImageBitmapOptions = []
ImageBitmapRenderingContext = []
ImageCapture = []
@@ -1206,6 +1222,7 @@ ImageDecodeOptions = []
ImageDecodeResult = []
ImageDecoder = []
ImageDecoderInit = []
+ImageEncodeOptions = []
ImageOrientation = []
ImageTrack = ["EventTarget"]
ImageTrackList = []
@@ -1232,6 +1249,7 @@ KeyboardEvent = [
"UiEvent",
]
KeyboardEventInit = []
+KeyframeAnimationOptions = []
KeyframeEffect = ["AnimationEffect"]
KeyframeEffectOptions = []
L10nElement = []
@@ -1328,6 +1346,10 @@ MediaTrackConstraintSet = []
MediaTrackConstraints = []
MediaTrackSettings = []
MediaTrackSupportedConstraints = []
+MemoryAttribution = []
+MemoryAttributionContainer = []
+MemoryBreakdownEntry = []
+MemoryMeasurement = []
MessageChannel = []
MessageEvent = ["Event"]
MessageEventInit = []
@@ -1410,6 +1432,7 @@ OfflineAudioContext = [
OfflineAudioContextOptions = []
OfflineResourceList = ["EventTarget"]
OffscreenCanvas = ["EventTarget"]
+OffscreenCanvasRenderingContext2d = []
OpenWindowEventDetail = []
OptionalEffectTiming = []
OrientationLockType = []
@@ -1549,6 +1572,7 @@ PushSubscriptionJson = []
PushSubscriptionKeys = []
PushSubscriptionOptions = []
PushSubscriptionOptionsInit = []
+QueryOptions = []
QueuingStrategy = []
QueuingStrategyInit = []
RadioNodeList = ["NodeList"]
@@ -1636,6 +1660,7 @@ RtcOutboundRtpStreamStats = []
RtcPeerConnection = ["EventTarget"]
RtcPeerConnectionIceEvent = ["Event"]
RtcPeerConnectionIceEventInit = []
+RtcPeerConnectionState = []
RtcPriorityType = []
RtcRtcpParameters = []
RtcRtpCodecParameters = []
@@ -1696,6 +1721,7 @@ SecurityPolicyViolationEvent = ["Event"]
SecurityPolicyViolationEventDisposition = []
SecurityPolicyViolationEventInit = []
Selection = []
+SelectionMode = []
Serial = ["EventTarget"]
SerialInputSignals = []
SerialOptions = []
@@ -2473,6 +2499,24 @@ WebKitCssMatrix = [
WebSocket = ["EventTarget"]
WebSocketDict = []
WebSocketElement = []
+WebTransport = []
+WebTransportBidirectionalStream = []
+WebTransportCloseInfo = []
+WebTransportCongestionControl = []
+WebTransportDatagramDuplexStream = []
+WebTransportDatagramStats = []
+WebTransportError = ["DomException"]
+WebTransportErrorOptions = []
+WebTransportErrorSource = []
+WebTransportHash = []
+WebTransportOptions = []
+WebTransportReceiveStream = ["ReadableStream"]
+WebTransportReceiveStreamStats = []
+WebTransportReliabilityMode = []
+WebTransportSendStream = ["WritableStream"]
+WebTransportSendStreamOptions = []
+WebTransportSendStreamStats = []
+WebTransportStats = []
WebglColorBufferFloat = []
WebglCompressedTextureAstc = []
WebglCompressedTextureAtc = []
@@ -2510,6 +2554,8 @@ WorkletOptions = []
WritableStream = []
WritableStreamDefaultController = []
WritableStreamDefaultWriter = []
+WriteCommandType = []
+WriteParams = []
XPathExpression = []
XPathNsResolver = []
XPathResult = []
@@ -2536,7 +2582,7 @@ XrBoundedReferenceSpace = [
]
XrEye = []
XrFrame = []
-XrHand = ["XrHandJoint"]
+XrHand = []
XrHandJoint = []
XrHandedness = []
XrInputSource = []
@@ -2545,8 +2591,11 @@ XrInputSourceEvent = ["Event"]
XrInputSourceEventInit = []
XrInputSourcesChangeEvent = ["Event"]
XrInputSourcesChangeEventInit = []
-XrJointPose = []
-XrJointSpace = []
+XrJointPose = ["XrPose"]
+XrJointSpace = [
+ "EventTarget",
+ "XrSpace",
+]
XrLayer = ["EventTarget"]
XrPermissionDescriptor = []
XrPermissionStatus = [
@@ -2592,7 +2641,7 @@ gpu_shader_stage = []
gpu_texture_usage = []
[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-futures]
-version = "0.4.34"
+version = "0.4.37"
[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3.34"
+version = "0.3.37"