summaryrefslogtreecommitdiffstats
path: root/vendor/windows-bindgen/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/windows-bindgen/Cargo.toml
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/windows-bindgen/Cargo.toml')
-rw-r--r--vendor/windows-bindgen/Cargo.toml31
1 files changed, 22 insertions, 9 deletions
diff --git a/vendor/windows-bindgen/Cargo.toml b/vendor/windows-bindgen/Cargo.toml
index 285ac36ad..0997de862 100644
--- a/vendor/windows-bindgen/Cargo.toml
+++ b/vendor/windows-bindgen/Cargo.toml
@@ -10,11 +10,11 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "windows-bindgen"
-version = "0.49.0"
+version = "0.51.1"
authors = ["Microsoft"]
-description = "Code gen support for the windows and windows-sys crates"
+description = "Windows metadata compiler"
readme = "readme.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/microsoft/windows-rs"
@@ -23,10 +23,23 @@ repository = "https://github.com/microsoft/windows-rs"
default-target = "x86_64-pc-windows-msvc"
targets = []
-[dependencies.metadata]
-version = "0.49.0"
-package = "windows-metadata"
+[dependencies.proc-macro2]
+version = "1.0"
+features = ["span-locations"]
-[dependencies.tokens]
-version = "0.48.0"
-package = "windows-tokens"
+[dependencies.rayon]
+version = "1.7"
+
+[dependencies.syn]
+version = "2.0"
+features = [
+ "full",
+ "extra-traits",
+]
+
+[dependencies.windows-metadata]
+version = "0.51.1"
+
+[features]
+default = ["metadata"]
+metadata = []