summaryrefslogtreecommitdiffstats
path: root/vendor/windows_i686_gnu
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/windows_i686_gnu
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/windows_i686_gnu')
-rw-r--r--vendor/windows_i686_gnu/.cargo-checksum.json1
-rw-r--r--vendor/windows_i686_gnu/Cargo.toml23
-rw-r--r--vendor/windows_i686_gnu/build.rs10
-rw-r--r--vendor/windows_i686_gnu/lib/libwindows.abin0 -> 14009016 bytes
-rw-r--r--vendor/windows_i686_gnu/src/lib.rs1
5 files changed, 35 insertions, 0 deletions
diff --git a/vendor/windows_i686_gnu/.cargo-checksum.json b/vendor/windows_i686_gnu/.cargo-checksum.json
new file mode 100644
index 000000000..a0bef12b2
--- /dev/null
+++ b/vendor/windows_i686_gnu/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"f95c1a0b734504bc6253cde876d9ad2f143a76b659efa7e784a3044f7e9739e6","build.rs":"000703af30e0803750ab7d9a087728f109f058144368e8f53532ddcae317ab73","lib/libwindows.a":"f28803c6d102552e78964963df6806923c18c9f406b9d2ba06fe4790214c4059","src/lib.rs":"bdf6c7cf1fc01f69cc1d4e52948d1f246fdd310e6323d5dd1efd23f1daf382ef"},"package":"180e6ccf01daf4c426b846dfc66db1fc518f074baa793aa7d9b9aaeffad6a3b6"} \ No newline at end of file
diff --git a/vendor/windows_i686_gnu/Cargo.toml b/vendor/windows_i686_gnu/Cargo.toml
new file mode 100644
index 000000000..c0b43d759
--- /dev/null
+++ b/vendor/windows_i686_gnu/Cargo.toml
@@ -0,0 +1,23 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "windows_i686_gnu"
+version = "0.36.1"
+authors = ["Microsoft"]
+description = "Code gen support for the windows crate"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/microsoft/windows-rs"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+targets = []
diff --git a/vendor/windows_i686_gnu/build.rs b/vendor/windows_i686_gnu/build.rs
new file mode 100644
index 000000000..9dbe7e540
--- /dev/null
+++ b/vendor/windows_i686_gnu/build.rs
@@ -0,0 +1,10 @@
+fn main() {
+ let target = std::env::var("TARGET").unwrap();
+ if target != "i686-pc-windows-gnu" && target != "i686-uwp-windows-gnu" {
+ return;
+ }
+
+ let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap();
+
+ println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display());
+}
diff --git a/vendor/windows_i686_gnu/lib/libwindows.a b/vendor/windows_i686_gnu/lib/libwindows.a
new file mode 100644
index 000000000..81ae58bf3
--- /dev/null
+++ b/vendor/windows_i686_gnu/lib/libwindows.a
Binary files differ
diff --git a/vendor/windows_i686_gnu/src/lib.rs b/vendor/windows_i686_gnu/src/lib.rs
new file mode 100644
index 000000000..0c9ac1ac8
--- /dev/null
+++ b/vendor/windows_i686_gnu/src/lib.rs
@@ -0,0 +1 @@
+#![no_std]