summaryrefslogtreecommitdiffstats
path: root/vendor/windows_i686_msvc-0.28.0
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/windows_i686_msvc-0.28.0
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/windows_i686_msvc-0.28.0')
-rw-r--r--vendor/windows_i686_msvc-0.28.0/.cargo-checksum.json1
-rw-r--r--vendor/windows_i686_msvc-0.28.0/Cargo.toml18
-rw-r--r--vendor/windows_i686_msvc-0.28.0/build.rs9
-rw-r--r--vendor/windows_i686_msvc-0.28.0/lib/windows.libbin0 -> 4703748 bytes
-rw-r--r--vendor/windows_i686_msvc-0.28.0/src/lib.rs1
5 files changed, 29 insertions, 0 deletions
diff --git a/vendor/windows_i686_msvc-0.28.0/.cargo-checksum.json b/vendor/windows_i686_msvc-0.28.0/.cargo-checksum.json
new file mode 100644
index 000000000..ef7b639dd
--- /dev/null
+++ b/vendor/windows_i686_msvc-0.28.0/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"8c8c6113ee828ccef69d771c62f6927d976bb41f15cd5eac80c1842ea976a2c1","build.rs":"6a2fae3a459fbdda42b17bed99272dc5c451178eb75f9c8b60dc850c2d8808db","lib/windows.lib":"2ce264a67ae694e3135d95f2963af9cfe18caf09cf90eb9ca1772227f3cddedb","src/lib.rs":"01ba4719c80b6fe911b091a7c05124b64eeece964e09c058ef8f9805daca546b"},"package":"51d5158a43cc43623c0729d1ad6647e62fa384a3d135fd15108d37c683461f64"} \ No newline at end of file
diff --git a/vendor/windows_i686_msvc-0.28.0/Cargo.toml b/vendor/windows_i686_msvc-0.28.0/Cargo.toml
new file mode 100644
index 000000000..6365634b3
--- /dev/null
+++ b/vendor/windows_i686_msvc-0.28.0/Cargo.toml
@@ -0,0 +1,18 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "windows_i686_msvc"
+version = "0.28.0"
+authors = ["Microsoft"]
+description = "Code gen support for the windows crate"
+license = "MIT OR Apache-2.0"
diff --git a/vendor/windows_i686_msvc-0.28.0/build.rs b/vendor/windows_i686_msvc-0.28.0/build.rs
new file mode 100644
index 000000000..beb291126
--- /dev/null
+++ b/vendor/windows_i686_msvc-0.28.0/build.rs
@@ -0,0 +1,9 @@
+fn main() {
+ if std::env::var("TARGET").unwrap() != "i686-pc-windows-msvc" {
+ return;
+ }
+
+ let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap();
+
+ println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display());
+}
diff --git a/vendor/windows_i686_msvc-0.28.0/lib/windows.lib b/vendor/windows_i686_msvc-0.28.0/lib/windows.lib
new file mode 100644
index 000000000..3e2b9a984
--- /dev/null
+++ b/vendor/windows_i686_msvc-0.28.0/lib/windows.lib
Binary files differ
diff --git a/vendor/windows_i686_msvc-0.28.0/src/lib.rs b/vendor/windows_i686_msvc-0.28.0/src/lib.rs
new file mode 100644
index 000000000..8b1378917
--- /dev/null
+++ b/vendor/windows_i686_msvc-0.28.0/src/lib.rs
@@ -0,0 +1 @@
+