summaryrefslogtreecommitdiffstats
path: root/vendor/winnow/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 18:31:44 +0000
commitc23a457e72abe608715ac76f076f47dc42af07a5 (patch)
tree2772049aaf84b5c9d0ed12ec8d86812f7a7904b6 /vendor/winnow/Cargo.toml
parentReleasing progress-linux version 1.73.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-c23a457e72abe608715ac76f076f47dc42af07a5.tar.xz
rustc-c23a457e72abe608715ac76f076f47dc42af07a5.zip
Merging upstream version 1.74.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/winnow/Cargo.toml')
-rw-r--r--vendor/winnow/Cargo.toml21
1 files changed, 13 insertions, 8 deletions
diff --git a/vendor/winnow/Cargo.toml b/vendor/winnow/Cargo.toml
index 760878da4..a44df6680 100644
--- a/vendor/winnow/Cargo.toml
+++ b/vendor/winnow/Cargo.toml
@@ -13,11 +13,12 @@
edition = "2021"
rust-version = "1.64.0"
name = "winnow"
-version = "0.5.0"
+version = "0.5.15"
include = [
"build.rs",
"src/**/*",
"Cargo.toml",
+ "Cargo.lock",
"LICENSE*",
"README.md",
"benches/**/*",
@@ -147,6 +148,10 @@ name = "contains_token"
harness = false
[[bench]]
+name = "iter"
+harness = false
+
+[[bench]]
name = "number"
harness = false
@@ -168,16 +173,16 @@ path = "examples/json/bench.rs"
harness = false
required-features = ["std"]
-[dependencies.anstyle]
-version = "0.3.5"
+[dependencies.anstream]
+version = "0.3.2"
optional = true
-[dependencies.anstyle-stream]
-version = "0.2.2"
+[dependencies.anstyle]
+version = "1.0.1"
optional = true
[dependencies.is-terminal]
-version = "0.4.7"
+version = "0.4.9"
optional = true
[dependencies.memchr]
@@ -193,7 +198,7 @@ optional = true
version = "0.3.0"
[dev-dependencies.criterion]
-version = "0.3.6"
+version = "0.5.1"
[dev-dependencies.doc-comment]
version = "0.3"
@@ -217,10 +222,10 @@ version = "0.2.0"
[features]
alloc = []
debug = [
+ "dep:anstream",
"dep:anstyle",
"dep:is-terminal",
"dep:terminal_size",
- "dep:anstyle-stream",
]
default = ["std"]
simd = ["dep:memchr"]