summaryrefslogtreecommitdiffstats
path: root/vendor/xshell/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-19 09:26:03 +0000
commit9918693037dce8aa4bb6f08741b6812923486c18 (patch)
tree21d2b40bec7e6a7ea664acee056eb3d08e15a1cf /vendor/xshell/Cargo.toml
parentReleasing progress-linux version 1.75.0+dfsg1-5~progress7.99u1. (diff)
downloadrustc-9918693037dce8aa4bb6f08741b6812923486c18.tar.xz
rustc-9918693037dce8aa4bb6f08741b6812923486c18.zip
Merging upstream version 1.76.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/xshell/Cargo.toml')
-rw-r--r--vendor/xshell/Cargo.toml21
1 files changed, 16 insertions, 5 deletions
diff --git a/vendor/xshell/Cargo.toml b/vendor/xshell/Cargo.toml
index 781152f51..0f3d3e0d3 100644
--- a/vendor/xshell/Cargo.toml
+++ b/vendor/xshell/Cargo.toml
@@ -13,15 +13,26 @@
edition = "2021"
rust-version = "1.59"
name = "xshell"
-version = "0.2.3"
+version = "0.2.5"
authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
-exclude = [".github/", "bors.toml", "rustfmt.toml", "cbench", "mock_bin/"]
+exclude = [
+ ".github/",
+ "bors.toml",
+ "rustfmt.toml",
+ "cbench",
+ "mock_bin/",
+]
description = "Utilities for quick shell scripting in Rust"
-categories = ["development-tools::build-utils", "filesystem"]
+readme = "README.md"
+categories = [
+ "development-tools::build-utils",
+ "filesystem",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/matklad/xshell"
-resolver = "2"
+
[dependencies.xshell-macros]
-version = "=0.2.3"
+version = "=0.2.5"
+
[dev-dependencies.anyhow]
version = "1.0.56"