summaryrefslogtreecommitdiffstats
path: root/vendor/zerofrom/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /vendor/zerofrom/Cargo.toml
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/zerofrom/Cargo.toml')
-rw-r--r--vendor/zerofrom/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/vendor/zerofrom/Cargo.toml b/vendor/zerofrom/Cargo.toml
new file mode 100644
index 000000000..77d60c093
--- /dev/null
+++ b/vendor/zerofrom/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "zerofrom"
+version = "0.1.1"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "ZeroFrom trait for constructing"
+keywords = [
+ "zerocopy",
+ "serialization",
+ "lifetime",
+ "borrow",
+]
+categories = [
+ "data-structures",
+ "caching",
+ "no-std",
+]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.zerofrom-derive]
+version = "0.1.0"
+optional = true
+
+[features]
+alloc = []
+default = ["alloc"]
+derive = ["zerofrom-derive"]