summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdebian/bin/rust-lld2
-rw-r--r--debian/control18
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/rust-lldb.links2
-rw-r--r--debian/rust-llvm.links10
5 files changed, 18 insertions, 18 deletions
diff --git a/debian/bin/rust-lld b/debian/bin/rust-lld
index 9d5fdd03d..b3880d793 100755
--- a/debian/bin/rust-lld
+++ b/debian/bin/rust-lld
@@ -6,4 +6,4 @@
# However the tests fail for other reasons, namely we can't build rustdoc
# (which runs the tests) in wasm32 yet. So this is just WIP at the moment,
# it is not expect to work nor to be installed on user machines.
-exec /usr/bin/lld-17 "${@/#-Wl,/}"
+exec /usr/bin/lld-16 "${@/#-Wl,/}"
diff --git a/debian/control b/debian/control
index b7bbc418e..907ceb62b 100644
--- a/debian/control
+++ b/debian/control
@@ -19,12 +19,12 @@ Build-Depends:
cargo:native (>= 1.72.0+dfsg) <!pkg.rustc.dlstage0>,
rustc:native (>= 1.72.0+dfsg) <!pkg.rustc.dlstage0>,
rustc:native (<= 1.73.0++) <!pkg.rustc.dlstage0>,
- llvm-17-dev:native,
- llvm-17-tools:native,
+ llvm-16-dev:native,
+ llvm-16-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm17t64 (>= 1:17.0.0),
- libclang-rt-17-dev:native,
+ libllvm16 (>= 1:16.0.0),
+ libclang-rt-16-dev:native,
cmake (>= 3.0),
# needed by some vendor crates
pkgconf,
@@ -54,7 +54,7 @@ Build-Depends:
Build-Depends-Indep:
wasi-libc (>= 0.0~git20230821.ec4566b~~) <!nowasm>,
wasi-libc (<= 0.0~git20230821.ec4566b++) <!nowasm>,
- clang-17:native,
+ clang-16:native,
Build-Conflicts: gdb-minimal <!nocheck>
Standards-Version: 4.6.2
Homepage: http://www.rust-lang.org/
@@ -168,7 +168,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
# Embeds wasi-libc so doesn't need to depend on it
# None of its licenses require source redistrib, so no need for Built-Using
Recommends:
- lld-17, clang-17,
+ lld-16, clang-16,
Suggests:
# nodejs contains wasi-node for running the program
nodejs (>= 12.16),
@@ -214,7 +214,7 @@ Description: Rust debugger (gdb)
Package: rust-lldb
Architecture: all
# When updating, also update rust-lldb.links
-Depends: lldb-17, ${misc:Depends}, python3-lldb-17
+Depends: lldb-16, ${misc:Depends}, python3-lldb-16
Replaces: rustc (<< 1.1.0+dfsg1-1)
Description: Rust debugger (lldb)
Rust is a curly-brace, block-structured expression language. It
@@ -245,9 +245,9 @@ Replaces:
Depends:
${misc:Depends},
# lld and clang are needed for wasm compilation
- lld-17, clang-17,
+ lld-16, clang-16,
# llvm is needed for llvm-dwp for split-debuginfo=packed
- llvm-17
+ llvm-16
Description: Rust LLVM integration
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
diff --git a/debian/rules b/debian/rules
index 940623614..eb6a2a4d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,8 +34,8 @@ export RUST_LONG_VERSION
DEB_DESTDIR := $(CURDIR)/debian/tmp
# Use system LLVM (comment out to use vendored LLVM)
-LLVM_VERSION = 17
-OLD_LLVM_VERSION = 16
+LLVM_VERSION = 16
+OLD_LLVM_VERSION = 15
# Cargo-specific flags
export LIBSSH2_SYS_USE_PKG_CONFIG=1
# Make it easier to test against a custom LLVM
diff --git a/debian/rust-lldb.links b/debian/rust-lldb.links
index 444f6fc87..e82fca912 100644
--- a/debian/rust-lldb.links
+++ b/debian/rust-lldb.links
@@ -1 +1 @@
-usr/share/man/man1/lldb-17.1.gz usr/share/man/man1/rust-lldb.1.gz
+usr/share/man/man1/lldb-16.1.gz usr/share/man/man1/rust-lldb.1.gz
diff --git a/debian/rust-llvm.links b/debian/rust-llvm.links
index 5796ed868..7090a480d 100644
--- a/debian/rust-llvm.links
+++ b/debian/rust-llvm.links
@@ -1,9 +1,9 @@
-usr/bin/lld-17 usr/bin/rust-lld
-usr/bin/clang-17 usr/bin/rust-clang
-usr/bin/llvm-dwp-17 usr/bin/rust-llvm-dwp
+usr/bin/lld-16 usr/bin/rust-lld
+usr/bin/clang-16 usr/bin/rust-clang
+usr/bin/llvm-dwp-16 usr/bin/rust-llvm-dwp
# for -Z gcc-ld=lld, see compiler/rustc_codegen_ssa/src/back/link.rs for logic
usr/bin/rust-lld usr/lib/rustlib/${env:DEB_HOST_RUST_TYPE}/bin/gcc-ld/ld
usr/bin/rust-lld usr/lib/rustlib/${env:DEB_HOST_RUST_TYPE}/bin/gcc-ld/ld64
# For applications that use cargo-binutils, e.g. grcov
-usr/bin/llvm-profdata-17 usr/lib/rustlib/${env:DEB_HOST_RUST_TYPE}/bin/llvm-profdata
-usr/bin/llvm-cov-17 usr/lib/rustlib/${env:DEB_HOST_RUST_TYPE}/bin/llvm-cov
+usr/bin/llvm-profdata-16 usr/lib/rustlib/${env:DEB_HOST_RUST_TYPE}/bin/llvm-profdata
+usr/bin/llvm-cov-16 usr/lib/rustlib/${env:DEB_HOST_RUST_TYPE}/bin/llvm-cov