summaryrefslogtreecommitdiffstats
path: root/compiler/rustc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc/Cargo.toml')
-rw-r--r--compiler/rustc/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
new file mode 100644
index 000000000..27ee3dd2a
--- /dev/null
+++ b/compiler/rustc/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "rustc-main"
+version = "0.0.0"
+edition = "2021"
+
+[dependencies]
+rustc_driver = { path = "../rustc_driver" }
+
+# Make sure rustc_codegen_ssa ends up in the sysroot, because this
+# crate is intended to be used by codegen backends, which may not be in-tree.
+rustc_codegen_ssa = { path = "../rustc_codegen_ssa" }
+# Make sure rustc_smir ends up in the sysroot, because this
+# crate is intended to be used by stable MIR consumers, which are not in-tree
+rustc_smir = { path = "../rustc_smir" }
+
+[dependencies.jemalloc-sys]
+version = "0.5.0"
+optional = true
+features = ['unprefixed_malloc_on_supported_platforms']
+
+[features]
+jemalloc = ['jemalloc-sys']
+llvm = ['rustc_driver/llvm']
+max_level_info = ['rustc_driver/max_level_info']
+rustc_use_parallel_compiler = ['rustc_driver/rustc_use_parallel_compiler']